summaryrefslogtreecommitdiff
path: root/dev-scheme/gauche/gauche-0.9.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-scheme/gauche/gauche-0.9.3.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-scheme/gauche/gauche-0.9.3.3.ebuild')
-rw-r--r--dev-scheme/gauche/gauche-0.9.3.3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-scheme/gauche/gauche-0.9.3.3.ebuild b/dev-scheme/gauche/gauche-0.9.3.3.ebuild
new file mode 100644
index 000000000000..011ca66086e3
--- /dev/null
+++ b/dev-scheme/gauche/gauche-0.9.3.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools eutils
+
+MY_P="${P^g}"
+
+DESCRIPTION="A Unix system friendly Scheme Interpreter"
+HOMEPAGE="http://practical-scheme.net/gauche/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6 test"
+
+RDEPEND="sys-libs/gdbm"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/openssl )"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9-rpath.patch
+ "${FILESDIR}"/${PN}-0.9-gauche.m4.patch
+ "${FILESDIR}"/${PN}-0.9-ext-ldflags.patch
+ "${FILESDIR}"/${PN}-0.9-xz-info.patch
+ "${FILESDIR}"/${PN}-0.9-rfc.tls.patch
+ "${FILESDIR}"/${P}-gauche.threads.patch
+ "${FILESDIR}"/${P}-file.util.patch
+)
+
+src_prepare() {
+ default
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ --with-slib="${EPREFIX}"/usr/share/slib
+}
+
+src_test() {
+ emake -j1 -s check
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install-pkg install-doc
+ dodoc AUTHORS ChangeLog HACKING README
+}