summaryrefslogtreecommitdiff
path: root/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
commit5a1e5a6812ca9c9555657cce48fe09d2ffa44401 (patch)
tree5c040bbee9184b24f26b05031a2448e62f6df38a /dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild
parent2c4066122b66fa1eb3e37846f9a6e14529a553d8 (diff)
gentoo auto-resync : 02:12:2022 - 08:55:37
Diffstat (limited to 'dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild')
-rw-r--r--dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild b/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild
new file mode 100644
index 000000000000..7c88a2ac40d5
--- /dev/null
+++ b/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Guile bindings of libgcrypt"
+HOMEPAGE="https://notabug.org/cwebber/guile-gcrypt"
+SRC_URI="https://notabug.org/cwebber/guile-gcrypt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="
+ >=dev-scheme/guile-2.0.11:=
+ dev-libs/libgcrypt:0=
+"
+DEPEND="${RDEPEND}"
+
+# guile generates ELF files without use of C or machine code
+# It's a portage's false positive. bug #677600
+QA_PREBUILT='*[.]go'
+
+src_prepare() {
+ default
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+
+ # upstream tag on top of source tree. has no autogenerated files
+ eautoreconf
+}