summaryrefslogtreecommitdiff
path: root/dev-tcltk/tclx/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-tcltk/tclx/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-tcltk/tclx/files')
-rw-r--r--dev-tcltk/tclx/files/tclx-8.4-ldflags.patch13
-rw-r--r--dev-tcltk/tclx/files/tclx-8.4-varinit.patch11
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-tcltk/tclx/files/tclx-8.4-ldflags.patch b/dev-tcltk/tclx/files/tclx-8.4-ldflags.patch
new file mode 100644
index 000000000000..40acfda25fd9
--- /dev/null
+++ b/dev-tcltk/tclx/files/tclx-8.4-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index b812bbe..069337c 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -123,7 +123,7 @@ OBJEXT = @OBJEXT@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ @LDFLAGS@
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
+ TCL_DEFS = @TCL_DEFS@
diff --git a/dev-tcltk/tclx/files/tclx-8.4-varinit.patch b/dev-tcltk/tclx/files/tclx-8.4-varinit.patch
new file mode 100644
index 000000000000..08fe7d881191
--- /dev/null
+++ b/dev-tcltk/tclx/files/tclx-8.4-varinit.patch
@@ -0,0 +1,11 @@
+--- tclx8.4/generic/tclXdup.c.varinit 2006-02-03 15:54:38.000000000 -0500
++++ tclx8.4/generic/tclXdup.c 2006-02-03 15:54:53.000000000 -0500
+@@ -202,7 +202,7 @@
+ {
+ Tcl_Channel newChannel;
+ int bindFnum, fnum;
+- char *srcChannelId, *targetChannelId;
++ char *srcChannelId = NULL, *targetChannelId;
+
+ if ((objc < 2) || (objc > 3)) {
+ return TclX_WrongArgs (interp, objv [0],