summaryrefslogtreecommitdiff
path: root/dev-tcltk/tclx/tclx-8.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-tcltk/tclx/tclx-8.4.4.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-tcltk/tclx/tclx-8.4.4.ebuild')
-rw-r--r--dev-tcltk/tclx/tclx-8.4.4.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-tcltk/tclx/tclx-8.4.4.ebuild b/dev-tcltk/tclx/tclx-8.4.4.ebuild
new file mode 100644
index 000000000000..cbc91e94b9c4
--- /dev/null
+++ b/dev-tcltk/tclx/tclx-8.4.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib
+
+DESCRIPTION="A set of extensions to TCL"
+HOMEPAGE="http://tclx.sourceforge.net"
+SRC_URI="https://github.com/flightaware/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+IUSE="threads"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="dev-lang/tcl:0="
+RDEPEND="${DEPEND}"
+
+# tests broken, bug #279283
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-8.4-varinit.patch
+ "${FILESDIR}"/${PN}-8.4-ldflags.patch
+)
+
+src_prepare() {
+ sed \
+ -e '/CC=/s:-pipe::g' \
+ -i tclconfig/tcl.m4 configure || die
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable threads) \
+ --enable-shared \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)/"
+
+ # adjust install_name on darwin
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i \
+ -e 's:^\(SHLIB_LD\W.*\)$:\1 -install_name ${pkglibdir}/$@:' \
+ "${S}"/Makefile || die 'sed failed'
+ fi
+}
+
+src_install() {
+ default
+ doman doc/*.[n3]
+}