summaryrefslogtreecommitdiff
path: root/dev-tcltk/tclxml/tclxml-3.2.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-tcltk/tclxml/tclxml-3.2.7-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-tcltk/tclxml/tclxml-3.2.7-r1.ebuild')
-rw-r--r--dev-tcltk/tclxml/tclxml-3.2.7-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-tcltk/tclxml/tclxml-3.2.7-r1.ebuild b/dev-tcltk/tclxml/tclxml-3.2.7-r1.ebuild
new file mode 100644
index 000000000000..5c4a298b68e7
--- /dev/null
+++ b/dev-tcltk/tclxml/tclxml-3.2.7-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Pure Tcl implementation of an XML parser"
+HOMEPAGE="http://tclxml.sourceforge.net/"
+SRC_URI="https://github.com/wjoye/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc sparc x86"
+IUSE="debug threads"
+
+DEPEND="
+ >=dev-lang/tcl-8.2:=
+ >=dev-libs/libxml2-2.6.9
+ dev-libs/libxslt
+ >=dev-tcltk/tcllib-1.2
+ dev-libs/expat"
+# test? ( dev-tcltk/tclparser )
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-fix-implicit-declarations.patch
+ "${FILESDIR}"/${P}-bool.patch
+)
+
+src_configure() {
+ local myconf=""
+
+ use threads && myconf="${myconf} --enable-threads"
+
+ econf ${myconf} \
+ --with-xml2-config="${EPREFIX}"/usr/bin/xml2-config \
+ --with-xslt-config="${EPREFIX}"/usr/bin/xslt-config \
+ --with-tclinclude="${EPREFIX}"/usr/include \
+ --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable amd64 64bit) \
+ $(use_enable debug symbols)
+}