summaryrefslogtreecommitdiff
path: root/dev-tcltk/tkcon/tkcon-2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-tcltk/tkcon/tkcon-2.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-tcltk/tkcon/tkcon-2.5.ebuild')
-rw-r--r--dev-tcltk/tkcon/tkcon-2.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-tcltk/tkcon/tkcon-2.5.ebuild b/dev-tcltk/tkcon/tkcon-2.5.ebuild
new file mode 100644
index 000000000000..b3a7f5c5fcd8
--- /dev/null
+++ b/dev-tcltk/tkcon/tkcon-2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils multilib
+
+DESCRIPTION="Tk GUI console"
+HOMEPAGE="http://tkcon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="dev-lang/tk"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local tclver="$(echo 'puts $tcl_version' | tclsh)"
+ local instdir=/usr/$(get_libdir)/tcl${tclver}/${PN}2.5
+ dodir ${instdir}
+ cp -pP pkgIndex.tcl tkcon.tcl "${D}"${instdir} || die
+ dodir /usr/bin
+ dosym ${instdir}/tkcon.tcl /usr/bin/tkcon
+ dodoc README.txt
+ if use doc; then
+ dohtml doc/*
+ fi
+}