summaryrefslogtreecommitdiff
path: root/dev-tcltk/togl/togl-2.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-tcltk/togl/togl-2.0-r3.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-tcltk/togl/togl-2.0-r3.ebuild')
-rw-r--r--dev-tcltk/togl/togl-2.0-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-tcltk/togl/togl-2.0-r3.ebuild b/dev-tcltk/togl/togl-2.0-r3.ebuild
new file mode 100644
index 000000000000..5791c04242e4
--- /dev/null
+++ b/dev-tcltk/togl/togl-2.0-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=Togl${PV}
+
+DESCRIPTION="A Tk widget for OpenGL rendering"
+HOMEPAGE="http://togl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +threads"
+
+RDEPEND="
+ dev-lang/tk:*
+ virtual/opengl
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+# tests directory is missing
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ sed \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-O2::g' \
+ -e 's:-pipe::g' \
+ -i configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+}
+
+src_install() {
+ HTML_DOCS=( doc/* )
+ default
+}