summaryrefslogtreecommitdiff
path: root/dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild')
-rw-r--r--dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild b/dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild
new file mode 100644
index 000000000000..5080e7e70cc1
--- /dev/null
+++ b/dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Visual Tcl is a high-quality application development environment"
+HOMEPAGE="http://vtcl.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+DEPEND="dev-lang/tk:*"
+RDEPEND="${DEPEND}"
+
+MY_DESTDIR=/usr/share/${PN}
+
+src_compile() {
+ sed -i 's,^\(VTCL_HOME=\).*,\1'${MY_DESTDIR}',g' vtcl || die "Path fixing failed."
+ sed -i 's,package require -exact Tk ,package require Tk ,' lib/tkcon.tcl || die "Tcl8.5 patch failed"
+}
+
+src_install() {
+ dodir ${MY_DESTDIR}
+ dobin vtcl
+ cp -r ./{demo,images,lib,sample,vtcl.tcl} "${D}/${MY_DESTDIR}" || die "Data installation failed."
+ if use doc; then
+ DOCS=( ChangeLog README doc/tutorial.txt )
+ HTML_DOCS=( doc/*html )
+ fi
+ einstalldocs
+}