summaryrefslogtreecommitdiff
path: root/dev-tex/bibtex2html/bibtex2html-1.99.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-tex/bibtex2html/bibtex2html-1.99.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-tex/bibtex2html/bibtex2html-1.99.ebuild')
-rw-r--r--dev-tex/bibtex2html/bibtex2html-1.99.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-tex/bibtex2html/bibtex2html-1.99.ebuild b/dev-tex/bibtex2html/bibtex2html-1.99.ebuild
new file mode 100644
index 000000000000..8ebac2b7cc61
--- /dev/null
+++ b/dev-tex/bibtex2html/bibtex2html-1.99.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A bibtex to HTML converter"
+HOMEPAGE="https://www.lri.fr/~filliatr/bibtex2html/"
+SRC_URI="https://www.lri.fr/~filliatr/ftp/bibtex2html/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+RESTRICT="test"
+
+# With use doc we need a latex compiler to generate manual.pdf
+# hevea is used for manual.html
+# manual.tex needs fullpage.sty
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]
+ doc? ( virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-tex/hevea )"
+# We need tex-base for bibtex but also some bibtex styles, so we use latex-base
+RDEPEND="virtual/latex-base"
+
+PATCHES=( "${FILESDIR}/${PN}-1.88-destdir.patch" )
+
+src_prepare() {
+ default
+ # Avoid pre-stripped files
+ sed -i -e "s/strip/true/" Makefile.in || die
+ # For make install
+ use ocamlopt || sed -i 's/= opt /= noopt /' Makefile.in || die
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ if use ocamlopt ; then
+ emake opt
+ else
+ emake byte
+ fi
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README CHANGES
+ if use doc; then
+ dodoc -r manual.{pdf,html}
+ fi
+}