summaryrefslogtreecommitdiff
path: root/dev-tex/html2latex/html2latex-1.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-tex/html2latex/html2latex-1.1-r3.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-tex/html2latex/html2latex-1.1-r3.ebuild')
-rw-r--r--dev-tex/html2latex/html2latex-1.1-r3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-tex/html2latex/html2latex-1.1-r3.ebuild b/dev-tex/html2latex/html2latex-1.1-r3.ebuild
new file mode 100644
index 000000000000..dd5a18cfc929
--- /dev/null
+++ b/dev-tex/html2latex/html2latex-1.1-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Perl script to convert HTML files into formatted LaTeX"
+HOMEPAGE="http://html2latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="imagemagick libwww"
+
+DEPEND="dev-perl/HTML-Tree
+ dev-perl/XML-Simple
+ imagemagick? ( media-gfx/imagemagick )
+ libwww? ( dev-perl/libwww-perl )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # HTML::LaTex
+ cd HTML || die
+ perl-module_src_configure
+}
+
+src_compile() {
+ # HTML::LaTex
+ cd HTML || die
+ perl-module_src_compile
+}
+
+src_install() {
+ dobin html2latex
+ doman html2latex.1
+ dodoc README TODO
+
+ # HTML::LaTex
+ cd HTML || die
+ perl-module_src_install
+
+ # rm unwanted README.win
+ rm "${ED}"/usr/share/doc/${PF}/README.win.txt || die
+}