summaryrefslogtreecommitdiff
path: root/dev-tex/latexdiff/latexdiff-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-tex/latexdiff/latexdiff-1.1.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tex/latexdiff/latexdiff-1.1.0.ebuild')
-rw-r--r--dev-tex/latexdiff/latexdiff-1.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-tex/latexdiff/latexdiff-1.1.0.ebuild b/dev-tex/latexdiff/latexdiff-1.1.0.ebuild
new file mode 100644
index 000000000000..33a3bd4f7d9a
--- /dev/null
+++ b/dev-tex/latexdiff/latexdiff-1.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Compare two latex files and mark up significant differences"
+HOMEPAGE="http://www.ctan.org/tex-archive/support/latexdiff/ https://github.com/ftilmann/latexdiff/"
+SRC_URI="http://mirror.ctan.org/support/${PN}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8
+ dev-perl/Algorithm-Diff"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_test() {
+ emake test-ext
+}
+
+src_install() {
+ dobin latexdiff latexrevise latexdiff-vc
+ doman latexdiff.1 latexrevise.1 latexdiff-vc.1
+ dodoc README doc/latexdiff-man.pdf
+}