summaryrefslogtreecommitdiff
path: root/dev-tex/pgf/pgf-3.1.9a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-tex/pgf/pgf-3.1.9a.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-tex/pgf/pgf-3.1.9a.ebuild')
-rw-r--r--dev-tex/pgf/pgf-3.1.9a.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-tex/pgf/pgf-3.1.9a.ebuild b/dev-tex/pgf/pgf-3.1.9a.ebuild
new file mode 100644
index 000000000000..02e87d3a3e94
--- /dev/null
+++ b/dev-tex/pgf/pgf-3.1.9a.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit latex-package
+
+DESCRIPTION="The TeX Portable Graphic Format"
+HOMEPAGE="https://github.com/pgf-tikz/pgf"
+SRC_URI=" https://github.com/pgf-tikz/pgf/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~tamiko/distfiles/${P}-revisioned.xz
+ doc? ( https://github.com/pgf-tikz/pgf/releases/download/${PV}/pgfmanual-${PV}.pdf -> ${P}-pgfmanual.pdf )"
+
+LICENSE="GPL-2 LPPL-1.3c FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc source"
+
+RDEPEND="dev-texlive/texlive-latexrecommended"
+
+DOCS=( README.md doc/generic/pgf/ChangeLog doc/generic/pgf/RELEASE_NOTES.md )
+
+src_install() {
+ einstalldocs
+
+ insinto "${TEXMF}"
+ doins -r tex
+ insinto "${TEXMF}"/tex/generic/${PN}
+ newins "${WORKDIR}"/${P}-revisioned pgf.revision.tex
+
+ if use source ; then
+ doins -r source
+ fi
+
+ if use doc; then
+ cd "${S}/doc/generic/pgf" || die
+ docinto texdoc
+ # pgfmanual is now split from the main tar archive
+ newdoc "${DISTDIR}/${P}-pgfmanual.pdf" pgfmanual.pdf
+ doins -r images text-en version-*
+ rm version-for-dvisvgm/en/color.cfg || die # bug 700056
+
+ dosym "../../../doc/${PF}/texdoc" "${TEXMF}/doc/latex/${PN}"
+ docompress -x "/usr/share/doc/${P}/texdoc/"
+ fi
+}