summaryrefslogtreecommitdiff
path: root/dev-util/0xtools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-25 01:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-25 01:25:44 +0100
commitc25088d4fc442a7d6dc3a8d0498b43024888318d (patch)
treefdb19b6a9b3a20669ecb49f0ba8d9f435fbb4b1a /dev-util/0xtools
parentd80b870c42fbe218389ffaf86f0f2a39404deca1 (diff)
gentoo auto-resync : 25:09:2024 - 01:25:44
Diffstat (limited to 'dev-util/0xtools')
-rw-r--r--dev-util/0xtools/0xtools-1.2.4.ebuild62
-rw-r--r--dev-util/0xtools/0xtools-2.0.3-r1.ebuild (renamed from dev-util/0xtools/0xtools-2.0.2.ebuild)24
-rw-r--r--dev-util/0xtools/0xtools-2.0.3.ebuild70
-rw-r--r--dev-util/0xtools/0xtools-9999.ebuild40
-rw-r--r--dev-util/0xtools/Manifest8
5 files changed, 52 insertions, 152 deletions
diff --git a/dev-util/0xtools/0xtools-1.2.4.ebuild b/dev-util/0xtools/0xtools-1.2.4.ebuild
deleted file mode 100644
index 0b5161d406e2..000000000000
--- a/dev-util/0xtools/0xtools-1.2.4.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit python-single-r1 systemd toolchain-funcs
-
-DESCRIPTION="Always-on profiling for production systems"
-HOMEPAGE="https://0x.tools/
- https://github.com/tanelpoder/0xtools/"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/tanelpoder/${PN}.git"
-else
- SRC_URI="https://github.com/tanelpoder/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}"
-BDEPEND="${RDEPEND}"
-
-DOCS=( CHANGELOG.md README.md )
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
-
- sed -e "/^sys.path.append/s|(.*)|('$(python_get_sitedir)/${PN}')|" \
- -i bin/psn -i bin/schedlat || die
-}
-
-src_install() {
- # C executables and scripts
- exeinto /usr/bin
- doexe bin/{run_xcapture.sh,run_xcpu.sh,vmtop,xcapture}
-
- # Python executables
- python_domodule lib/${PN}
- python_doscript bin/psn
- python_doscript bin/schedlat
-
- # Service
- systemd_dounit xcapture.service
- systemd_dounit xcapture-restart.service
- systemd_dounit xcapture-restart.timer
-
- # Service config
- insinto /etc/default
- newins xcapture.default xcapture
-
- # Service logs
- keepdir /var/log/xcapture
-
- einstalldocs
-}
diff --git a/dev-util/0xtools/0xtools-2.0.2.ebuild b/dev-util/0xtools/0xtools-2.0.3-r1.ebuild
index 8f4e383cb9f6..395a7ccf798a 100644
--- a/dev-util/0xtools/0xtools-2.0.2.ebuild
+++ b/dev-util/0xtools/0xtools-2.0.3-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{11..12} )
-inherit python-single-r1 systemd toolchain-funcs
+inherit python-single-r1 systemd toolchain-funcs wrapper
DESCRIPTION="Always-on profiling for production systems"
HOMEPAGE="https://0x.tools/
@@ -26,11 +26,15 @@ LICENSE="GPL-2+"
SLOT="0"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="
+BDEPEND="
${PYTHON_DEPS}
"
-BDEPEND="
- ${RDEPEND}
+RDEPEND="
+ ${BDEPEND}
+ sys-power/cpupower
+ $(python_gen_cond_dep '
+ dev-util/bcc[${PYTHON_USEDEP}]
+ ')
"
DOCS=( CHANGELOG.md README.md )
@@ -43,9 +47,12 @@ src_compile() {
}
src_install() {
+ # "cpumhzturbo" requires "turbostat", which is not packaged,
+ # see bug: https://bugs.gentoo.org/939913
+
# C executables and scripts
exeinto /usr/bin
- doexe bin/{cpumhz,cpumhzturbo,vmtop,xcapture,xtop}
+ doexe bin/{cpumhz,vmtop,xcapture,xtop}
doexe bin/{run_xcapture.sh,run_xcpu.sh}
# Python executables
@@ -59,6 +66,13 @@ src_install() {
systemd_dounit xcapture-restart.service
systemd_dounit xcapture-restart.timer
+ # Setup for "xcapture-bpf".
+ exeinto "/lib/${PN}/xcapture"
+ doexe bin/xcapture-bpf
+ insinto "/lib/${PN}/xcapture"
+ doins bin/xcapture-bpf.c
+ make_wrapper xcapture-bpf "/lib/${PN}/xcapture/xcapture-bpf"
+
# Service config
insinto /etc/default
newins xcapture.default xcapture
diff --git a/dev-util/0xtools/0xtools-2.0.3.ebuild b/dev-util/0xtools/0xtools-2.0.3.ebuild
deleted file mode 100644
index 8f4e383cb9f6..000000000000
--- a/dev-util/0xtools/0xtools-2.0.3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{11..12} )
-
-inherit python-single-r1 systemd toolchain-funcs
-
-DESCRIPTION="Always-on profiling for production systems"
-HOMEPAGE="https://0x.tools/
- https://github.com/tanelpoder/0xtools/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/tanelpoder/${PN}.git"
-else
- SRC_URI="https://github.com/tanelpoder/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
-"
-BDEPEND="
- ${RDEPEND}
-"
-
-DOCS=( CHANGELOG.md README.md )
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
-
- sed -e "/^sys.path.append/s|(.*)|('$(python_get_sitedir)/${PN}')|" \
- -i bin/psn -i bin/schedlat || die
-}
-
-src_install() {
- # C executables and scripts
- exeinto /usr/bin
- doexe bin/{cpumhz,cpumhzturbo,vmtop,xcapture,xtop}
- doexe bin/{run_xcapture.sh,run_xcpu.sh}
-
- # Python executables
- python_domodule "lib/${PN}"
- python_doscript bin/psn
- python_doscript bin/schedlat
- python_doscript bin/syscallargs
-
- # Service
- systemd_dounit xcapture.service
- systemd_dounit xcapture-restart.service
- systemd_dounit xcapture-restart.timer
-
- # Service config
- insinto /etc/default
- newins xcapture.default xcapture
-
- # Service logs
- keepdir /var/log/xcapture
-
- einstalldocs
-}
diff --git a/dev-util/0xtools/0xtools-9999.ebuild b/dev-util/0xtools/0xtools-9999.ebuild
index 3b7026647b97..395a7ccf798a 100644
--- a/dev-util/0xtools/0xtools-9999.ebuild
+++ b/dev-util/0xtools/0xtools-9999.ebuild
@@ -1,31 +1,41 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{11..12} )
-inherit python-single-r1 systemd toolchain-funcs
+inherit python-single-r1 systemd toolchain-funcs wrapper
DESCRIPTION="Always-on profiling for production systems"
HOMEPAGE="https://0x.tools/
https://github.com/tanelpoder/0xtools/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/tanelpoder/${PN}.git"
else
SRC_URI="https://github.com/tanelpoder/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+
+ KEYWORDS="amd64 ~x86"
fi
LICENSE="GPL-2+"
SLOT="0"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}"
-BDEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ ${BDEPEND}
+ sys-power/cpupower
+ $(python_gen_cond_dep '
+ dev-util/bcc[${PYTHON_USEDEP}]
+ ')
+"
DOCS=( CHANGELOG.md README.md )
@@ -37,20 +47,32 @@ src_compile() {
}
src_install() {
+ # "cpumhzturbo" requires "turbostat", which is not packaged,
+ # see bug: https://bugs.gentoo.org/939913
+
# C executables and scripts
exeinto /usr/bin
- doexe bin/{run_xcapture.sh,run_xcpu.sh,vmtop,xcapture}
+ doexe bin/{cpumhz,vmtop,xcapture,xtop}
+ doexe bin/{run_xcapture.sh,run_xcpu.sh}
# Python executables
- python_domodule lib/${PN}
+ python_domodule "lib/${PN}"
python_doscript bin/psn
python_doscript bin/schedlat
+ python_doscript bin/syscallargs
# Service
systemd_dounit xcapture.service
systemd_dounit xcapture-restart.service
systemd_dounit xcapture-restart.timer
+ # Setup for "xcapture-bpf".
+ exeinto "/lib/${PN}/xcapture"
+ doexe bin/xcapture-bpf
+ insinto "/lib/${PN}/xcapture"
+ doins bin/xcapture-bpf.c
+ make_wrapper xcapture-bpf "/lib/${PN}/xcapture/xcapture-bpf"
+
# Service config
insinto /etc/default
newins xcapture.default xcapture
diff --git a/dev-util/0xtools/Manifest b/dev-util/0xtools/Manifest
index 6bddfccedd9c..a0afb203fcfa 100644
--- a/dev-util/0xtools/Manifest
+++ b/dev-util/0xtools/Manifest
@@ -1,8 +1,4 @@
-DIST 0xtools-1.2.4.tar.gz 61830 BLAKE2B 6221ded289bc4cf4c39527f35d1ad3ee43f41a60a4a9877056a5ff74fcdd203575d96edbf13af1d32bcc49465d87a2133a8dbec813ae9a5bb233b5fe2e4a36b3 SHA512 f835de65e783d9eb4b26f38be155961a2f4da91639c7e1e39df71cf8be17d27987c8749e44b7b6affe6cdc45c5f65c90be5b2cf22b2f37dcc2eb45452a384ff3
-DIST 0xtools-2.0.2.tar.gz 5989710 BLAKE2B 5e4efd4d21e3ed1fc8b1eed5378d25af3170f2386c738a68d28df5bad44ebdb88fd20a0b554d101b678c15131adb83ae786df1267c8333075c58ea58b8c2ce88 SHA512 5cb627e9b990063867869cdbbdefd7e2b6151410ac19950f683086c9200a8ba1f92192378779dbabc4efd91283cd23243a4b46259d97426331f823941b85883b
DIST 0xtools-2.0.3.tar.gz 5991280 BLAKE2B 26d71f43a0fbe72d38e675cc525fc91b4a738dd3a99ef6804f8855d15341a423d1b5c54ba9e015bea539d15617393d8994c1415a3ee0b74d2d49e97f6b243586 SHA512 012655d8d12fe5a853ccb9503471893ee09bf0fbbe5d3b3be52b5857cac965be63279546c240748d10d727abc2383b8cf2e91b07ffee69ae509494fb5c5d6767
-EBUILD 0xtools-1.2.4.ebuild 1359 BLAKE2B 16f5d4a8baf958a55eab1a130d18d39ac25d0e824889de9336abfc557e7980c9c8b74a438f00fb27846055ad749ca43d162124be26c376f1fd641c431a3b1be9 SHA512 ba018d77933c4e2e347a7817ace9f79ebb642b3f92080f09c386816fd3681b7a9d7a8d16526e29e2a63a6611ecf40362c37f15e0b37647c6bac0ca7a7fef4062
-EBUILD 0xtools-2.0.2.ebuild 1441 BLAKE2B 8de88d59aa58dac8b84dfbb5abb3ea617734ebeec66d40d7457e8a94de4b9d0e21dc60cc931e2dd3045b11eb09ebcc8223176d77e6fe5d4998a52cf139e49386 SHA512 b290b97c6469c902e25f7d72ef10e459d10e202f9dd4508ee41a89d8afae7e829b2c87a6e75115a4813c3a5a40627ad1119823a3f4a3a03308cbf4db236f6aae
-EBUILD 0xtools-2.0.3.ebuild 1441 BLAKE2B 8de88d59aa58dac8b84dfbb5abb3ea617734ebeec66d40d7457e8a94de4b9d0e21dc60cc931e2dd3045b11eb09ebcc8223176d77e6fe5d4998a52cf139e49386 SHA512 b290b97c6469c902e25f7d72ef10e459d10e202f9dd4508ee41a89d8afae7e829b2c87a6e75115a4813c3a5a40627ad1119823a3f4a3a03308cbf4db236f6aae
-EBUILD 0xtools-9999.ebuild 1360 BLAKE2B 1a710510aeade291b21d2b1e124244ae2ce5e5666909198a45fb3a4544fe88bfa5f964fb6a98d510f3a0544336a10538e50396663c7d0e47394f02fcf4c4b2ca SHA512 7404eda4db8655977d3db08b594c9f2861937e3663faa57781f19e2697d57310a2ccb08db8df3f617b1ce6006f1caa7d07b79baa123d97e971fb703d6a29c089
+EBUILD 0xtools-2.0.3-r1.ebuild 1829 BLAKE2B 383e1378f8acf72c726bf43d4c900dd62e2aac6dd5ca91f08136e40e1f06d3af85d5f0aba61f8fc84e0fbdcc1b1d65c12d2e07c14969a37c2e3e2e611f003efd SHA512 6c7d6713915b9be0eea6cc0ff6e3fe803b4b22e8403822ada5a42f2c2a1e5685cd47342dbab571e935445ed8af8027335b1a73fa2bf1eeaa087db04cd8214f2a
+EBUILD 0xtools-9999.ebuild 1829 BLAKE2B 383e1378f8acf72c726bf43d4c900dd62e2aac6dd5ca91f08136e40e1f06d3af85d5f0aba61f8fc84e0fbdcc1b1d65c12d2e07c14969a37c2e3e2e611f003efd SHA512 6c7d6713915b9be0eea6cc0ff6e3fe803b4b22e8403822ada5a42f2c2a1e5685cd47342dbab571e935445ed8af8027335b1a73fa2bf1eeaa087db04cd8214f2a
MISC metadata.xml 1292 BLAKE2B b7e2505d33b7af4424dc4336a7d8d1536ed70f92e4dccccf725a54473b109f7718adac34960b5238753336c6b2da5fd0e49def8ae249509c4b0c9e4bc42a89cf SHA512 0ecf2c2bab2cf03656f980788cf05849c3d2e5905f70753b03f76615da377a5463b3d30decddc3a97eaf83d9bef55e31ce104ca6cd459eb0f116c9edeba0edf2