summaryrefslogtreecommitdiff
path: root/dev-util/Tensile/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-util/Tensile/files
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-util/Tensile/files')
-rw-r--r--dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch4
-rw-r--r--dev-util/Tensile/files/Tensile-5.0.2-fix-arch-parse.patch12
-rw-r--r--dev-util/Tensile/files/Tensile-5.0.2-gentoopath.patch75
-rw-r--r--dev-util/Tensile/files/Tensile-5.0.2-gfx1031.patch104
-rw-r--r--dev-util/Tensile/files/Tensile-5.0.2-use-ninja.patch21
5 files changed, 214 insertions, 2 deletions
diff --git a/dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch b/dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch
index 6fda0ddc6a8d..da135e3b38ee 100644
--- a/dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch
+++ b/dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch
@@ -17,7 +17,7 @@ Index: Tensile-rocm-4.3.0/Tensile/Source/lib/CMakeLists.txt
if(TENSILE_USE_LLVM)
- find_package(LLVM 13.0 QUIET CONFIG)
-+ find_package(LLVM PATHS /opt/gentoo/usr/lib/llvm/roc QUIET CONFIG)
++ find_package(LLVM PATHS @GENTOO_PORTAGE_EPREFIX@/usr/lib/llvm/roc QUIET CONFIG)
if(NOT LLVM_FOUND)
find_package(LLVM 12.0 QUIET CONFIG)
if(NOT LLVM_FOUND)
@@ -30,7 +30,7 @@ Index: Tensile-rocm-4.3.0/Tensile/Common.py
print2(" %24s: %8s (unspecified)" % (key, defaultValue))
- globalParameters["ROCmPath"] = "/opt/rocm"
-+ globalParameters["ROCmPath"] = "/opt/gentoo/usr"
++ globalParameters["ROCmPath"] = "@GENTOO_PORTAGE_EPREFIX@/usr"
if "ROCM_PATH" in os.environ:
globalParameters["ROCmPath"] = os.environ.get("ROCM_PATH")
if "TENSILE_ROCM_PATH" in os.environ:
diff --git a/dev-util/Tensile/files/Tensile-5.0.2-fix-arch-parse.patch b/dev-util/Tensile/files/Tensile-5.0.2-fix-arch-parse.patch
new file mode 100644
index 000000000000..47bee8819c44
--- /dev/null
+++ b/dev-util/Tensile/files/Tensile-5.0.2-fix-arch-parse.patch
@@ -0,0 +1,12 @@
+Index: Tensile-rocm-5.0.1/Tensile/Tensile.py
+===================================================================
+--- Tensile-rocm-5.0.1.orig/Tensile/Tensile.py
++++ Tensile-rocm-5.0.1/Tensile/Tensile.py
+@@ -97,7 +97,6 @@ def addCommonArguments(argParser):
+ """
+
+ (key, value) = par.split("=")
+- value = eval(value)
+ return (key, value)
+
+ argParser.add_argument("-d", "--device", dest="device", type=int, \
diff --git a/dev-util/Tensile/files/Tensile-5.0.2-gentoopath.patch b/dev-util/Tensile/files/Tensile-5.0.2-gentoopath.patch
new file mode 100644
index 000000000000..b8b59af5184e
--- /dev/null
+++ b/dev-util/Tensile/files/Tensile-5.0.2-gentoopath.patch
@@ -0,0 +1,75 @@
+Fix incorrect path in scripts and CMakeLists, in order to build tensile_client
+===================================================================
+--- Tensile-rocm-5.0.2.orig/Tensile/Source/client/CMakeLists.txt
++++ Tensile-rocm-5.0.2/Tensile/Source/client/CMakeLists.txt
+@@ -56,3 +56,5 @@ endif()
+ foreach(arch IN LISTS TENSILE_GPU_ARCHS)
+ target_link_libraries(tensile_client PRIVATE "--amdgpu-target=${arch}")
+ endforeach(arch)
++
++target_link_libraries(tensile_client PRIVATE LLVMSupport)
+Index: Tensile-rocm-5.0.2/Tensile/Source/lib/CMakeLists.txt
+===================================================================
+--- Tensile-rocm-5.0.2.orig/Tensile/Source/lib/CMakeLists.txt
++++ Tensile-rocm-5.0.2/Tensile/Source/lib/CMakeLists.txt
+@@ -47,7 +47,7 @@ set(tensile_sources ${tensile_sources}
+ )
+
+ if(TENSILE_USE_LLVM)
+- find_package(LLVM 13.0 QUIET CONFIG)
++ find_package(LLVM PATHS @GENTOO_PORTAGE_EPREFIX@/usr/lib/llvm/roc QUIET CONFIG)
+ if(NOT LLVM_FOUND)
+ find_package(LLVM 12.0 QUIET CONFIG)
+ if(NOT LLVM_FOUND)
+Index: Tensile-rocm-5.0.2/Tensile/Common.py
+===================================================================
+--- Tensile-rocm-5.0.2.orig/Tensile/Common.py
++++ Tensile-rocm-5.0.2/Tensile/Common.py
+@@ -1873,7 +1873,7 @@ def assignGlobalParameters( config ):
+ else:
+ print2(" %24s: %8s (unspecified)" % (key, defaultValue))
+
+- globalParameters["ROCmPath"] = "/opt/rocm"
++ globalParameters["ROCmPath"] = "@GENTOO_PORTAGE_EPREFIX@/usr"
+ if "ROCM_PATH" in os.environ:
+ globalParameters["ROCmPath"] = os.environ.get("ROCM_PATH")
+ if "TENSILE_ROCM_PATH" in os.environ:
+Index: Tensile-rocm-5.0.2/Tensile/ClientWriter.py
+===================================================================
+--- Tensile-rocm-5.0.2.orig/Tensile/ClientWriter.py
++++ Tensile-rocm-5.0.2/Tensile/ClientWriter.py
+@@ -205,7 +205,7 @@ def getBuildClientLibraryScript(buildPat
+ import io
+ runScriptFile = io.StringIO()
+
+- callCreateLibraryCmd = globalParameters["ScriptPath"] + "/bin/TensileCreateLibrary"
++ callCreateLibraryCmd = "TensileCreateLibrary"
+
+
+ if globalParameters["MergeFiles"]:
+Index: Tensile-rocm-5.0.2/Tensile/GenerateSummations.py
+===================================================================
+--- Tensile-rocm-5.0.2.orig/Tensile/GenerateSummations.py
++++ Tensile-rocm-5.0.2/Tensile/GenerateSummations.py
+@@ -57,7 +57,7 @@ def createLibraryForBenchmark(logicPath,
+ Selection.
+ """
+
+- pythonExePath = os.path.join(os.path.dirname(os.path.realpath(__file__)), "bin", "TensileCreateLibrary")
++ pythonExePath = "TensileCreateLibrary"
+ args = [pythonExePath, \
+ "--merge-files", "--new-client-only", "--no-short-file-names", "--no-library-print-debug", \
+ "--architecture=all", "--code-object-version=V3", "--cxx-compiler=hipcc", "--library-format=yaml", \
+Index: Tensile-rocm-5.0.2/HostLibraryTests/CMakeLists.txt
+===================================================================
+--- Tensile-rocm-5.0.2.orig/HostLibraryTests/CMakeLists.txt
++++ Tensile-rocm-5.0.2/HostLibraryTests/CMakeLists.txt
+@@ -135,7 +135,7 @@ set(test_sources ${test_sources}
+ )
+
+ if(TENSILE_USE_LLVM)
+- find_package(LLVM 13.0 QUIET CONFIG)
++ find_package(LLVM PATHS @GENTOO_PORTAGE_EPREFIX@/usr/lib/llvm/roc QUIET CONFIG)
+ if(NOT LLVM_FOUND)
+ find_package(LLVM 12.0 QUIET CONFIG)
+ if(NOT LLVM_FOUND)
diff --git a/dev-util/Tensile/files/Tensile-5.0.2-gfx1031.patch b/dev-util/Tensile/files/Tensile-5.0.2-gfx1031.patch
new file mode 100644
index 000000000000..17925cfd49e0
--- /dev/null
+++ b/dev-util/Tensile/files/Tensile-5.0.2-gfx1031.patch
@@ -0,0 +1,104 @@
+Index: Tensile-rocm-5.0.1/pytest.ini
+===================================================================
+--- Tensile-rocm-5.0.1.orig/pytest.ini
++++ Tensile-rocm-5.0.1/pytest.ini
+@@ -87,6 +87,7 @@ markers =
+ xfail-gfx1011: architecture
+ xfail-gfx1012: architecture
+ xfail-gfx1030: architecture
++ xfail-gfx1031: architecture
+ skip-gfx000: architecture
+ skip-gfx900: architecture
+ skip-gfx906: architecture
+@@ -96,3 +97,4 @@ markers =
+ skip-gfx1011: architecture
+ skip-gfx1012: architecture
+ skip-gfx1030: architecture
++ skip-gfx1031: architecture
+Index: Tensile-rocm-5.0.1/Tensile/Common.py
+===================================================================
+--- Tensile-rocm-5.0.1.orig/Tensile/Common.py
++++ Tensile-rocm-5.0.1/Tensile/Common.py
+@@ -198,7 +198,7 @@ globalParameters["MergeFiles"] = True
+ globalParameters["NumMergedFiles"] = 1 # The number of files that kernels should be split between when merging
+
+ globalParameters["MaxFileName"] = 64 # If a file name would be longer than this, shorten it with a hash.
+-globalParameters["SupportedISA"] = [(8,0,3), (9,0,0), (9,0,6), (9,0,8), (9,0,10), (10,1,0), (10,1,1), (10,1,2), (10,3,0)] # assembly kernels writer supports these architectures
++globalParameters["SupportedISA"] = [(8,0,3), (9,0,0), (9,0,6), (9,0,8), (9,0,10), (10,1,0), (10,1,1), (10,1,2), (10,3,0),(10,3,1)] # assembly kernels writer supports these architectures
+
+ globalParameters["GenerateManifestAndExit"] = False # Output manifest file with list of expected library objects and exit
+ globalParameters["NewClient"] = 2 # Old client deprecated: NewClient must be set to 2.
+@@ -264,7 +264,7 @@ architectureMap = {
+ 'gfx906':'vega20', 'gfx906:xnack+':'vega20', 'gfx906:xnack-':'vega20',
+ 'gfx908':'arcturus','gfx908:xnack+':'arcturus', 'gfx908:xnack-':'arcturus',
+ 'gfx90a':'aldebaran', 'gfx90a:xnack+':'aldebaran', 'gfx90a:xnack-':'aldebaran',
+- 'gfx1010':'navi10', 'gfx1011':'navi12', 'gfx1012':'navi14', 'gfx1030':'navi21'
++ 'gfx1010':'navi10', 'gfx1011':'navi12', 'gfx1012':'navi14', 'gfx1030':'navi21', 'gfx1031':'navi22'
+ }
+
+ def getArchitectureName(gfxName):
+Index: Tensile-rocm-5.0.1/Tensile/KernelWriterAssembly.py
+===================================================================
+--- Tensile-rocm-5.0.1.orig/Tensile/KernelWriterAssembly.py
++++ Tensile-rocm-5.0.1/Tensile/KernelWriterAssembly.py
+@@ -2364,7 +2364,7 @@ class KernelWriterAssembly(KernelWriter)
+
+ # integer i8x4
+ elif kernel["ProblemType"]["DataType"].isInt8x4():
+- if self.version == (9,0,6) or self.version == (9,0,8) or self.version == (9,0,10) or self.version == (10,3,0):
++ if self.version == (9,0,6) or self.version == (9,0,8) or self.version == (9,0,10) or self.version == (10,3,0) or self.version == (10,3,1):
+ for b in range(0, kernel["ThreadTile1"]):
+ for a in range(0, kernel["ThreadTile0"]):
+ for iui in range(0, innerUnroll):
+Index: Tensile-rocm-5.0.1/Tensile/Source/CMakeLists.txt
+===================================================================
+--- Tensile-rocm-5.0.1.orig/Tensile/Source/CMakeLists.txt
++++ Tensile-rocm-5.0.1/Tensile/Source/CMakeLists.txt
+@@ -47,7 +47,7 @@ if(NOT DEFINED CXX_VERSION_STRING)
+ endif()
+
+ if(CMAKE_CXX_COMPILER STREQUAL "hipcc")
+- set(TENSILE_GPU_ARCHS gfx803 gfx900 gfx906:xnack- gfx908:xnack- gfx90a:xnack- gfx1010 gfx1011 gfx1012 gfx1030 CACHE STRING "GPU architectures")
++ set(TENSILE_GPU_ARCHS gfx803 gfx900 gfx906:xnack- gfx908:xnack- gfx90a:xnack- gfx1010 gfx1011 gfx1012 gfx1030 gfx1031 CACHE STRING "GPU architectures")
+ else()
+ set(TENSILE_GPU_ARCHS gfx803 gfx900 gfx906 gfx908 gfx90a CACHE STRING "GPU architectures")
+ endif()
+Index: Tensile-rocm-5.0.1/Tensile/Source/lib/include/Tensile/AMDGPU.hpp
+===================================================================
+--- Tensile-rocm-5.0.1.orig/Tensile/Source/lib/include/Tensile/AMDGPU.hpp
++++ Tensile-rocm-5.0.1/Tensile/Source/lib/include/Tensile/AMDGPU.hpp
+@@ -62,7 +62,8 @@ namespace Tensile
+ gfx1010 = 1010,
+ gfx1011 = 1011,
+ gfx1012 = 1012,
+- gfx1030 = 1030
++ gfx1030 = 1030,
++ gfx1031 = 1031
+ };
+
+ AMDGPU();
+Index: Tensile-rocm-5.0.1/Tensile/Source/lib/include/Tensile/Serialization/Predicates.hpp
+===================================================================
+--- Tensile-rocm-5.0.1.orig/Tensile/Source/lib/include/Tensile/Serialization/Predicates.hpp
++++ Tensile-rocm-5.0.1/Tensile/Source/lib/include/Tensile/Serialization/Predicates.hpp
+@@ -215,6 +215,7 @@ namespace Tensile
+ iot::enumCase(io, value, "gfx1011", AMDGPU::Processor::gfx1011);
+ iot::enumCase(io, value, "gfx1012", AMDGPU::Processor::gfx1012);
+ iot::enumCase(io, value, "gfx1030", AMDGPU::Processor::gfx1030);
++ iot::enumCase(io, value, "gfx1031", AMDGPU::Processor::gfx1031);
+ }
+ };
+ } // namespace Serialization
+Index: Tensile-rocm-5.0.1/Tensile/Source/lib/source/AMDGPU.cpp
+===================================================================
+--- Tensile-rocm-5.0.1.orig/Tensile/Source/lib/source/AMDGPU.cpp
++++ Tensile-rocm-5.0.1/Tensile/Source/lib/source/AMDGPU.cpp
+@@ -82,6 +82,8 @@ namespace Tensile
+ return stream << "gfx1012";
+ case AMDGPU::Processor::gfx1030:
+ return stream << "gfx1030";
++ case AMDGPU::Processor::gfx1031:
++ return stream << "gfx1031";
+ }
+ return stream;
+ }
diff --git a/dev-util/Tensile/files/Tensile-5.0.2-use-ninja.patch b/dev-util/Tensile/files/Tensile-5.0.2-use-ninja.patch
new file mode 100644
index 000000000000..485ec992d808
--- /dev/null
+++ b/dev-util/Tensile/files/Tensile-5.0.2-use-ninja.patch
@@ -0,0 +1,21 @@
+diff --git a/Tensile/ClientExecutable.py b/Tensile/ClientExecutable.py
+index ca3809f..2d1d83b 100644
+--- a/Tensile/ClientExecutable.py
++++ b/Tensile/ClientExecutable.py
+@@ -36,6 +36,7 @@ class CMakeEnvironment:
+
+ args = ['cmake']
+ args += itertools.chain.from_iterable([ ['-D', '{}={}'.format(key, value)] for key,value in self.options.items()])
++ args += itertools.chain.from_iterable([ ['-G', 'Ninja'], [ '-D', 'CMAKE_EXPORT_COMPILE_COMMANDS=ON' ] ])
+ args += [self.sourceDir]
+
+ Common.print2(' '.join(args))
+@@ -43,7 +44,7 @@ class CMakeEnvironment:
+ subprocess.check_call(args, cwd=Common.ensurePath(self.buildDir))
+
+ def build(self):
+- args = ['make', '-j']
++ args = ['ninja']
+ Common.print2(' '.join(args))
+ with Common.ClientExecutionLock():
+ subprocess.check_call(args, cwd=self.buildDir)