summaryrefslogtreecommitdiff
path: root/dev-util/anjuta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-util/anjuta
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-util/anjuta')
-rw-r--r--dev-util/anjuta/Manifest2
-rw-r--r--dev-util/anjuta/anjuta-3.28.0.ebuild136
2 files changed, 138 insertions, 0 deletions
diff --git a/dev-util/anjuta/Manifest b/dev-util/anjuta/Manifest
index f2f64bd9ab8a..eab0d171ad46 100644
--- a/dev-util/anjuta/Manifest
+++ b/dev-util/anjuta/Manifest
@@ -1,3 +1,5 @@
DIST anjuta-3.22.0.tar.xz 6363016 BLAKE2B 8b02f3dc0f97d0e195039cfd462bb6db64199c92d689fbf751e8a88141f65a4dc604bbf848342d73e398ba755e89b3d934df375aad50c9cee12c38df8a8c2d9e SHA512 64689392bfe6102698ef8a1ce62aac37bffd793b917ef6ffc53cb5b8aa9eb5b8961a999c32db559e9e348bcf46a7ec0ca9448100910b52885ddff898a62f3295
+DIST anjuta-3.28.0.tar.xz 6382736 BLAKE2B 8872736d80d0a09d35706ef69c0de56c84b9abf025f9552ae4b21b0b51c3ab8ad93f07dd1564601422890e92155cc7be80bae8de77106035621a54316608832b SHA512 c8de0b0debf0a511d6c50fe2582077a33c04290a045cce637c05c15df984cc3e8ee942c0c3a75bfd01c48e6c302d5424565c4e54fe6eb118c87a3590563505ef
EBUILD anjuta-3.22.0.ebuild 3520 BLAKE2B a537f055c2f8fc5f5411512ad248abcc3f5af309617d09f3d0191481ddea3802a60ab27b06a3e2ff1c6e93879692d3ea2f43ffcfe132d6b2d1cc1dd3f4fbc1ba SHA512 5e19000cbe233a2688ebc24afd74f761b6395576b5ed3bf83f3870cfa7a855d10650e447853250a93ee2c9c1b366291a1240998401b7c7f613ab5816befa7530
+EBUILD anjuta-3.28.0.ebuild 3572 BLAKE2B d69d7ee46afa8a95980c795824090afa96f4d5b3778fe7a9d597be41001b8c8ea8e68dfd63d8aade4ca8c5b467d93a22f32e495fc5979d6e5cd29a86e5626f5e SHA512 d1668c8f3b3b5f9bf2b1fa056a470cef0c68e74fa3287a40348e1b84705c52f6718f02e2db9e3058832939f306e2e1d3efe38b8b81fc254cdb7990242fc7171d
MISC metadata.xml 562 BLAKE2B 928b16bacff2417a1b50749486d2dcd656184b6cd7bce6f17e534d253ab2e1af854e18bf40f3188714e973b9c49f1b2691d031bdaef0ec73d9a4844c05b99218 SHA512 c452f34b8489e3faeb8c272282233341e22c958f04d750d54e07c487895aab8b03f4df096e1f07fdb7686a0295c770cb1fcf38fdca01f71730e991148013d82f
diff --git a/dev-util/anjuta/anjuta-3.28.0.ebuild b/dev-util/anjuta/anjuta-3.28.0.ebuild
new file mode 100644
index 000000000000..998c1d399632
--- /dev/null
+++ b/dev-util/anjuta/anjuta-3.28.0.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+# libanjuta-language-vala.so links to a specific slot of libvala; we want to
+# avoid automagic behavior.
+VALA_MIN_API_VERSION="0.36"
+VALA_MAX_API_VERSION="${VALA_MIN_API_VERSION}"
+
+inherit gnome2 flag-o-matic readme.gentoo-r1 python-single-r1 vala
+
+DESCRIPTION="A versatile IDE for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Anjuta"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug devhelp glade +introspection packagekit subversion terminal test vala"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# FIXME: automagically uses libgda:6 if available
+# FIXME: make python dependency non-automagic
+COMMON_DEPEND="
+ >=dev-libs/glib-2.34:2[dbus]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.10:3
+ >=dev-libs/libxml2-2.4.23
+ >=dev-libs/gdl-3.5.5:3=
+ >=x11-libs/gtksourceview-3:3.0
+
+ sys-devel/autogen
+
+ >=gnome-extra/libgda-5:5=
+ dev-util/ctags
+
+ x11-libs/libXext
+ x11-libs/libXrender
+
+ ${PYTHON_DEPS}
+
+ devhelp? ( >=dev-util/devhelp-3.7.4:= )
+ glade? ( >=dev-util/glade-3.12:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ subversion? (
+ >=dev-vcs/subversion-1.8:=
+ >=net-libs/serf-1.2:1=
+ >=dev-libs/apr-1:=
+ >=dev-libs/apr-util-1:= )
+ terminal? ( >=x11-libs/vte-0.27.6:2.91 )
+ vala? ( $(vala_depend) )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.1
+ sys-devel/bison
+ sys-devel/flex
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ !!dev-libs/gnome-build
+ test? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xml-dtd:4.5 )
+ app-text/yelp-tools
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# yelp-tools, gi-common and gnome-common are required by eautoreconf
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if use vala; then
+ DISABLE_AUTOFORMATTING="yes"
+ DOC_CONTENTS="To create a generic vala project you will need to specify
+desired valac versioned binary to be used, to do that you
+will need to:
+1. Go to 'Build' -> 'Configure project'
+2. Add 'VALAC=/usr/bin/valac-X.XX' (respecting quotes) to
+'Configure options'."
+ fi
+
+ # COPYING is used in Anjuta's help/about entry
+ DOCS="AUTHORS ChangeLog COPYING FUTURE MAINTAINERS NEWS README ROADMAP THANKS TODO"
+
+ # Conflicts with -pg in a plugin, bug #266777
+ filter-flags -fomit-frame-pointer
+
+ # Do not build benchmarks, they are not installed and for dev purpose only
+ sed -e '/SUBDIRS =/ s/benchmark//' \
+ -i plugins/symbol-db/Makefile.{am,in} || die
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-neon \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable devhelp plugin-devhelp) \
+ $(use_enable glade plugin-glade) \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable packagekit) \
+ $(use_enable subversion plugin-subversion) \
+ $(use_enable subversion serf) \
+ $(use_enable terminal plugin-terminal) \
+ $(use_enable vala)
+}
+
+src_install() {
+ # COPYING is used in Anjuta's help/about entry
+ docompress -x "/usr/share/doc/${PF}/COPYING"
+
+ # Anjuta uses a custom rule to install DOCS, get rid of it
+ gnome2_src_install
+ rm -rf "${ED}"/usr/share/doc/${PN} || die "rm failed"
+
+ use vala && readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use vala && readme.gentoo_print_elog
+}