summaryrefslogtreecommitdiff
path: root/dev-util/aruba/aruba-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-util/aruba/aruba-0.8.1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-util/aruba/aruba-0.8.1.ebuild')
-rw-r--r--dev-util/aruba/aruba-0.8.1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-util/aruba/aruba-0.8.1.ebuild b/dev-util/aruba/aruba-0.8.1.ebuild
deleted file mode 100644
index 3d38cb5eb78c..000000000000
--- a/dev-util/aruba/aruba-0.8.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby24 ruby25"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_RECIPE_TEST="cucumber"
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="aruba.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Cucumber steps for driving out command line applications"
-HOMEPAGE="https://github.com/cucumber/aruba"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
-SLOT="0"
-IUSE=""
-
-DEPEND="${DEPEND} test? ( sys-devel/bc )"
-RDEPEND="${RDEPEND}"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.5.6 =dev-ruby/childprocess-0*
- >=dev-ruby/contracts-0.9:0
- >=dev-ruby/rspec-expectations-2.99:2
- >=dev-util/cucumber-1.3.19"
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:3 >=dev-ruby/bcat-0.6.2 )"
-
-all_ruby_prepare() {
- # Remove bundler-related code.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die
- rm Gemfile || die
-
- sed -i -e '/simplecov/I s:^:#:' \
- -e '/Before/,/^end/ s:^:#:' \
- spec/spec_helper.rb features/support/env.rb || die
- rm -f features/support/simplecov_setup.rb || die
- sed -i -e '1i require "time"' spec/spec_helper.rb || die
-
- # Remove references to git ls-files and fix childprocess dependency
- sed -i -e '/git ls-files/d' \
- -e '/childprocess/ s/0.5.6/0.5/' \
- aruba.gemspec || die
-
- # Avoid scenarios making broken assumptions on ${HOME}
- sed -i -e '/Scenario: Use ~ in path/i @wip' \
- features/api/core/expand_path.feature || die
- rm -f features/configuration/home_directory.feature || die
-}
-
-each_ruby_test() {
- RSPEC_VERSION=3 ruby-ng_rspec
- RUBYLIB="$(pwd)/lib" ruby-ng_cucumber
-}