summaryrefslogtreecommitdiff
path: root/dev-util/astyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-util/astyle
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/Manifest2
-rw-r--r--dev-util/astyle/astyle-3.1.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-util/astyle/Manifest b/dev-util/astyle/Manifest
index 03e89f8fea59..79af1e5b93ee 100644
--- a/dev-util/astyle/Manifest
+++ b/dev-util/astyle/Manifest
@@ -1,3 +1,5 @@
DIST astyle_3.0.1_linux.tar.gz 172483 BLAKE2B 4c80491cbcc976aa38ff294014df0dc01b39685eafdac6989bea082b1f61120c3985d14ff6db9f76606bbe8da1aaa344c2e0c9c2999a014f5d54384c0420cf97 SHA512 3e8d617c0ec89682bfb076081bb63ae9d44e897de0c85d5109b28adbbfe0620d5dacf59a4bd96ac30a5a4fcb3be136758e9c6fe2c69258b37956c212890a7158
+DIST astyle_3.1_linux.tar.gz 185589 BLAKE2B d0bc9bf3403de89d207f33ac885c7cd57fd1e71314c947e1593ee24ade9ce36c83c6fd8e7021f44d8d3b344ea3add63fa5a7b246c40f10193dc38b51e7ad36bc SHA512 2e8f13d291abda66bbba30174c364c81a81a490e0a21376f7da7cf471644c22caa37b9eefb100d093bf26d1a8bfa9d2f14b4c2a9b75b3cb84428b4514e277ff2
EBUILD astyle-3.0.1.ebuild 2203 BLAKE2B 970472e208b473cd2b20a1a59a15feb656467f141baeb48f686b1be35f3053077aa4d91caa1f2760ed20b6f6b7e41ccf93ca6996c201e6448ba21c3907681a5b SHA512 0b28bdc51d5a313ea9c297c14b680e31e2ea5c84a3a8d5dca92669c7e93f692c034a1492f5e2dbbad2c8cd881108b4f33c73f28b29bb04c1d6d5b5951253cd6d
+EBUILD astyle-3.1.ebuild 2211 BLAKE2B 334849824c8e8d1232aaecf82ba7442f5bd6f759a3b78a02de81c442d42c185b1b91b5cad5c08a107b4295695c1c2b3cf08277c5ecdd7745f1d535e8b89af3b6 SHA512 946100fa4355cbea972e5535571a3c8723d661bc9e869738af5e7625fce87e321b4d4b73bb69ca444780a50072f385b2d48b4b0e41eced428980ef330122d46b
MISC metadata.xml 753 BLAKE2B ddd9b5eb1eaf20f626bdb0b568c856f6e2bb548fff3b6271bd163d6b1f711e66635d2e3fd839c67421f92232a7a8c7343179a4a95e39266dcf44b91bffc0c2c3 SHA512 2896e9eb1f69dfcef21bbc4f622e0ee7e2a88ab882d1ed91623642d4b7ddabb3b9e4e060e1662254e40cd4cdc77f189dc6888dd509ca40633c1f197fb2e4610b
diff --git a/dev-util/astyle/astyle-3.1.ebuild b/dev-util/astyle/astyle-3.1.ebuild
new file mode 100644
index 000000000000..a84f1e30d840
--- /dev/null
+++ b/dev-util/astyle/astyle-3.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2
+
+DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="examples java static-libs"
+
+DEPEND="app-arch/xz-utils
+ java? ( >=virtual/jdk-1.6:= )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if use java ; then
+ java-pkg-opt-2_src_prepare
+ sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
+ -e "s:ar crs:$(tc-getAR) crs:" \
+ -i build/gcc/Makefile || die
+ else
+ default
+ fi
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ tc-export CXX
+ default
+}
+
+src_compile() {
+ # ../build/clang/Makefile is identical except for CXX line.
+ emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
+ ${PN} \
+ shared \
+ $(usev java) \
+ $(usex static-libs static '')
+}
+
+src_install() {
+ doheader src/${PN}.h
+
+ pushd src/bin >/dev/null || die
+ dobin ${PN}
+
+ # ex: libastyle.so.3.0.1
+ dolib.so lib${PN}.so.${PV}.0
+ # ex: libastyle.so.3
+ dosym lib${PN}.so.${PV}.0 /usr/$(get_libdir)/lib${PN}.so.$(get_major_version)
+ if use java ; then
+ dolib.so lib${PN}j.so.${PV}
+ dosym lib${PN}j.so.${PV} /usr/$(get_libdir)/lib${PN}j.so.$(get_major_version)
+ fi
+ if use static-libs ; then
+ dolib lib${PN}.a
+ fi
+ popd >/dev/null || die
+ if use examples ; then
+ docinto examples
+ dodoc -r file/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ local HTML_DOCS=( doc/. )
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -n "$REPLACING_VERSIONS" && "$(get_major_version $REPLACING_VERSIONS)" -lt 3 ]]; then
+ elog "Artistic Style 3.0 introduces new configuration verbiage more fitting"
+ elog "for modern use. Some options that were valid in 2.06 or older are now"
+ elog "deprecated. For more information, consult astyle's release notes at"
+ elog "http://astyle.sourceforge.net/news.html. To view offline, see:"
+ elog
+ elog "${ROOT}usr/share/doc/${P}/html"
+ fi
+}