summaryrefslogtreecommitdiff
path: root/dev-util/autodia/autodia-2.140.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-util/autodia/autodia-2.140.0-r2.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-util/autodia/autodia-2.140.0-r2.ebuild')
-rw-r--r--dev-util/autodia/autodia-2.140.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/autodia/autodia-2.140.0-r2.ebuild b/dev-util/autodia/autodia-2.140.0-r2.ebuild
new file mode 100644
index 000000000000..0798ccd75ec4
--- /dev/null
+++ b/dev-util/autodia/autodia-2.140.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_NAME=Autodia
+DIST_VERSION=2.14
+DIST_AUTHOR=TEEJAY
+inherit perl-module
+
+DESCRIPTION="Parses source code, XML or data and produces an XML document in Dia format"
+HOMEPAGE="http://www.aarontrevena.co.uk/opensource/autodia/ ${HOMEPAGE}"
+SRC_URI+=" mirror://gentoo/${DIST_NAME}-2.14-dbi.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="graphviz test"
+
+RDEPEND="
+ dev-perl/Template-Toolkit
+ dev-perl/XML-Simple
+ graphviz? (
+ dev-perl/GraphViz
+ )
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ )
+"
+
+PATCHES=( "${WORKDIR}"/${DIST_NAME}-2.14-dbi.patch )
+
+mydoc="DEVELOP"