summaryrefslogtreecommitdiff
path: root/dev-util/autoproject/autoproject-0.20_p5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-util/autoproject/autoproject-0.20_p5.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-util/autoproject/autoproject-0.20_p5.ebuild')
-rw-r--r--dev-util/autoproject/autoproject-0.20_p5.ebuild28
1 files changed, 11 insertions, 17 deletions
diff --git a/dev-util/autoproject/autoproject-0.20_p5.ebuild b/dev-util/autoproject/autoproject-0.20_p5.ebuild
index 239a51de78ec..9fd405115687 100644
--- a/dev-util/autoproject/autoproject-0.20_p5.ebuild
+++ b/dev-util/autoproject/autoproject-0.20_p5.ebuild
@@ -1,35 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
-
-inherit eutils
+EAPI=7
MY_PV=${PV%_p*}
DEB_VER=${PV#*_p}
+
DESCRIPTION="Start a programming project using autotools and a command line parser generator"
-HOMEPAGE="http://packages.debian.org/unstable/devel/autoproject"
-SRC_URI="mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}.orig.tar.gz
+HOMEPAGE="https://packages.debian.org/unstable/devel/autoproject"
+SRC_URI="
+ mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}.orig.tar.gz
mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}-${DEB_VER}.diff.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="test"
+RESTRICT="!test? ( test )"
-RDEPEND="sys-devel/automake
- sys-devel/autoconf"
+RDEPEND="
+ sys-devel/autoconf:*
+ sys-devel/automake:*"
DEPEND="${RDEPEND}
test? ( sys-apps/texinfo )"
S=${WORKDIR}/${PN}-${MY_PV}
-src_unpack() {
- unpack ${A}
- epatch ${PN}_${MY_PV}-${DEB_VER}.diff
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS NEWS README TODO ChangeLog
-}
+PATCHES=( "${WORKDIR}"/${PN}_${MY_PV}-${DEB_VER}.diff )