summaryrefslogtreecommitdiff
path: root/dev-util/autoproject
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-15 06:47:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-15 06:47:25 +0000
commitbc5dfb0671fb08c7da579b38b0e6abdd19da103f (patch)
tree1be81dbc48e2e0ec0cc322ab3062f1c56edd88be /dev-util/autoproject
parent4614848cbaec61bd1083af01a41f39c3b4a9e274 (diff)
gentoo auto-resync : 15:03:2024 - 06:47:25
Diffstat (limited to 'dev-util/autoproject')
-rw-r--r--dev-util/autoproject/Manifest3
-rw-r--r--dev-util/autoproject/autoproject-0.20_p15.ebuild54
-rw-r--r--dev-util/autoproject/files/autoproject-0.20_p15-getopt-cxx-conflict-noexcept.patch12
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/autoproject/Manifest b/dev-util/autoproject/Manifest
index d2336175e315..b55633171b4b 100644
--- a/dev-util/autoproject/Manifest
+++ b/dev-util/autoproject/Manifest
@@ -1,4 +1,7 @@
+AUX autoproject-0.20_p15-getopt-cxx-conflict-noexcept.patch 581 BLAKE2B a464f88ee7cc32afd26831985035b14688a896a0ddedf45ed0e128f5acf7c7665288f0ac546e6d8f953d28bafd1749ebd5199e7df2434f191dabd17cc1cfdaf7 SHA512 6074438b69436988d6474a6254bbd04a272c64d5c0e07669fff06266014a1571a77de2c32dbabb3535efe07c90c370e4aed89d269a87e8f037333d5154e061d6
+DIST autoproject_0.20-15.debian.tar.xz 7716 BLAKE2B a6969da3e5cac3aa02c6d878a13b8643867761c7f1c26a1bb1cc8469ac5e08f717a013418108c5b82aeb186b19677a1c1915e8b5d9785b650f7e44a976949f5f SHA512 ab74a3058b0a03d87baef5cdf0c8bb96dca71dea6ae28416249762542b076be7abdbe99f0ac9a8251bae1f2802f28af8aa6f087de64aef4f2c87a79877caebca
DIST autoproject_0.20-5.diff.gz 5287 BLAKE2B 3bc26c42876606c8a8a879a888ec1c51fac8de2b380ef10c1c346a35dcd4747b21264cf4d2161e55ea31d49393569a897aa98ff1b0a8576465fd5e06b77fd27a SHA512 156f8feff53936c3113bda9d8a3f2e19679f249656ace69aacb1f0a13ae93066eef49de3e5a268c47ed3e440144de629f6b84a477ecfc6a3f793c41412cc9b5a
DIST autoproject_0.20.orig.tar.gz 151101 BLAKE2B 657a4a4baae35b038392c2cc78a1ab0e657229587e64105f0a6150ce83c29cd2305b716b12e706ea31fc31f091f21fc8b00f89dbcd753453944ee26f7fbc01f1 SHA512 eb6ba12af96e03f4da51b6b9fc0db618180d92b8a363f30182013a003bb13f5b66ee12b28531a234f6035b64bda29bb0f838466ccbeaddbce06a437a18c05288
+EBUILD autoproject-0.20_p15.ebuild 1189 BLAKE2B eb16cb018b7d76afbf1b5135a3f3e081d401b91659c79008998350a58ef6eb388c3817795d99f1ee17c45efbcbb3e17d8958136369003a5a95fa9c3d486b0486 SHA512 4cedca9cc4947e68a60cccb51567387b0339ba4d96ae2e28b4af4f94536a649e2bc320c994ce717ebd20c4b80a4f040023694953671d4dbcb8f5fe98e80e5d7c
EBUILD autoproject-0.20_p5.ebuild 780 BLAKE2B b87914a2313cb936f8173c0315a3b83f40730832e5bc1d89bb228b186e760a8666ffd4e646e8e8824c99000db87587c60e1b82bccc9aa82822abc04a2a0326c3 SHA512 da26fe0b24245f65f6a5b64ed059e83de86b7ad6e70b0ddcaca70ffa8c501ad293c0578a97af4947343cb716302495f47aaa1ffe9fb92dee62285a08304c8601
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/dev-util/autoproject/autoproject-0.20_p15.ebuild b/dev-util/autoproject/autoproject-0.20_p15.ebuild
new file mode 100644
index 000000000000..1b3fed7d0827
--- /dev/null
+++ b/dev-util/autoproject/autoproject-0.20_p15.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=${PV%_p*}
+DEB_VER=${PV#*_p}
+
+inherit autotools
+
+DESCRIPTION="Start a programming project using autotools and a command line parser generator"
+HOMEPAGE="https://packages.debian.org/unstable/devel/autoproject"
+SRC_URI="
+ mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}-${DEB_VER}.debian.tar.xz
+"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/autoconf:*
+ dev-build/automake:*
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ sys-apps/texinfo
+ sys-devel/autogen
+ )
+"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+ "${FILESDIR}"/${PN}-0.20_p15-getopt-cxx-conflict-noexcept.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's:configure.in:configure.ac:' Makefile.am || die
+ eautoreconf
+}
+
+src_test() {
+ # chkclig: clig is an optional dep and it isn't packaged in Gentoo
+ # (nor in Debian since 2009)
+ # chkag: fails, unclear why
+ emake check XFAIL_TESTS="chkclig chkag"
+}
diff --git a/dev-util/autoproject/files/autoproject-0.20_p15-getopt-cxx-conflict-noexcept.patch b/dev-util/autoproject/files/autoproject-0.20_p15-getopt-cxx-conflict-noexcept.patch
new file mode 100644
index 000000000000..d881b7275ca3
--- /dev/null
+++ b/dev-util/autoproject/files/autoproject-0.20_p15-getopt-cxx-conflict-noexcept.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/872989
+--- a/lib/cli/c++/none/getopt.h
++++ b/lib/cli/c++/none/getopt.h
+@@ -131,7 +131,7 @@ struct option
+ /* Many other libraries have conflicting prototypes for getopt, with
+ differences in the consts, in stdlib.h. To avoid compilation
+ errors, only prototype getopt for the GNU C library. */
+-extern int getopt (int __argc, char *const *__argv, const char *__shortopts);
++extern int getopt (int __argc, char *const *__argv, const char *__shortopts) noexcept;
+ # else /* not __GNU_LIBRARY__ */
+ extern int getopt ();
+ # endif /* __GNU_LIBRARY__ */