summaryrefslogtreecommitdiff
path: root/dev-util/azuredatastudio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-31 05:49:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-31 05:49:48 +0000
commit8507777b4ede346b47aafc436295a51890b9cea3 (patch)
tree46a68cda616dee4775957fd9ef618c124b9b1b75 /dev-util/azuredatastudio
parentbb262580ec0b56a32797f121e627928d103e6bb1 (diff)
gentoo auto-resync : 31:12:2023 - 05:49:48
Diffstat (limited to 'dev-util/azuredatastudio')
-rw-r--r--dev-util/azuredatastudio/Manifest3
-rw-r--r--dev-util/azuredatastudio/azuredatastudio-1.47.0.ebuild101
-rw-r--r--dev-util/azuredatastudio/metadata.xml20
3 files changed, 124 insertions, 0 deletions
diff --git a/dev-util/azuredatastudio/Manifest b/dev-util/azuredatastudio/Manifest
new file mode 100644
index 000000000000..8d42de5b8195
--- /dev/null
+++ b/dev-util/azuredatastudio/Manifest
@@ -0,0 +1,3 @@
+DIST azuredatastudio-1.47.0-amd64.deb 138852252 BLAKE2B 20598aefb8ade4f1022213de1dfa17feddfb41ee0a241f8e9919e7573d00f3c3f81bbab947c9fec885a08b1e032a61616b1f49b943f3388c1edeb5502717e773 SHA512 7de1f1bafee735cfe7d52cb32324e38497ccb919a6322463b60bf2002af64546972f4ed207fdf0d9e55c48e33d7f5d7a9a3d10781c9c458edd4d18880ee5d310
+EBUILD azuredatastudio-1.47.0.ebuild 2170 BLAKE2B cc214ec74104ad58c6e82478209dd67fda83734ca549cd7e50109a0e3db69c4f0ffac2751e499433b9167d0f589b78fc17314fe63a720f66e8abfa8d270ae1a3 SHA512 66228e8dcbb522f992c61fa6009a6f72215427e29dfc0bcad0561309ff9866e7ce7ccd0bea1a989ea0340eee94b1b3d4d91428241a243d9f8c33fd439c530c8c
+MISC metadata.xml 822 BLAKE2B 72cadf27f137f7276f8cd3b3fc81afd0ac1eefa9f12e39aea8d81705454a17aa8d2b49de9d61c0523fda304dcf0363ef463d0b2fdbd04a524aa63a2ced6a6a6a SHA512 27dbc8a269df130994b8d59cefb193440b276638ef460f68d72e887dc02d40473218febc1ecf242a51f55593d90a3ea42255e4a8d8ce4237421c9e56e52c7030
diff --git a/dev-util/azuredatastudio/azuredatastudio-1.47.0.ebuild b/dev-util/azuredatastudio/azuredatastudio-1.47.0.ebuild
new file mode 100644
index 000000000000..4db21c59a2ec
--- /dev/null
+++ b/dev-util/azuredatastudio/azuredatastudio-1.47.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker xdg
+
+DESCRIPTION="Data management and development tool from Microsoft"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? (
+ https://azuredatastudio-update.azurewebsites.net/${PV}/linux-deb-x64/stable
+ -> ${P}-amd64.deb
+ )
+"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="kerberos"
+RESTRICT="bindist"
+
+# This is based on VSCode/VSCodium, so just copy their "RDEPEND".
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libcanberra[gtk3]
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+ kerberos? ( app-crypt/mit-krb5 )
+"
+DEPEND="
+ dev-libs/openssl-compat:1.0.0
+"
+BDEPEND="
+ dev-util/patchelf
+"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ unpack_deb "${A}"
+}
+
+src_prepare() {
+ default
+
+ cd "${S}/usr/share" || die
+
+ mv appdata metainfo || die
+ mv zsh/vendor-completions zsh/site-functions || die
+
+ cd "${PN}" || die
+
+ # Kerberos libs, same issue as VSCode/VSCodium.
+ if ! use kerberos ; then
+ rm -r resources/app/node_modules.asar.unpacked/kerberos || die
+ fi
+
+ # Patch "System.Security.Cryptography.Native.OpenSsl.so": *.so.10 -> *.so.1.0.0
+ local lib=System.Security.Cryptography.Native.OpenSsl.so
+ cd resources/app/extensions/mssql/sqltoolsservice/Linux/4.10.1.3 || die
+ patchelf --add-needed libcrypto.so.1.0.0 "${lib}" || die
+ patchelf --add-needed libssl.so.1.0.0 "${lib}" || die
+ patchelf --remove-needed libcrypto.so.10 "${lib}" || die
+ patchelf --remove-needed libssl.so.10 "${lib}" || die
+}
+
+src_install() {
+ cp -r . "${ED}" || die
+
+ dosym -r "/usr/share/${PN}/${PN}" "/usr/bin/${PN}"
+}
diff --git a/dev-util/azuredatastudio/metadata.xml b/dev-util/azuredatastudio/metadata.xml
new file mode 100644
index 000000000000..b89b462e8235
--- /dev/null
+++ b/dev-util/azuredatastudio/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Azure Data Studio is a data management and development tool with
+ connectivity to popular cloud and on-premises databases. Azure Data Studio
+ supports Windows, macOS, and Linux, with immediate capability to connect to
+ Azure SQL and SQL Server. Browse the extension library for more database
+ support options including MySQL, PostgreSQL, and MongoDB.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/microsoft/azuredatastudio/</bugs-to>
+ <remote-id type="github">microsoft/azuredatastudio</remote-id>
+ </upstream>
+</pkgmetadata>