summaryrefslogtreecommitdiff
path: root/dev-util/bats/bats-0.4.0_p20170219.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/bats/bats-0.4.0_p20170219.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/bats/bats-0.4.0_p20170219.ebuild')
-rw-r--r--dev-util/bats/bats-0.4.0_p20170219.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/bats/bats-0.4.0_p20170219.ebuild b/dev-util/bats/bats-0.4.0_p20170219.ebuild
new file mode 100644
index 000000000000..2abffbaffb56
--- /dev/null
+++ b/dev-util/bats/bats-0.4.0_p20170219.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMITHASH="03608115df2071fff4eaaff1605768c275e5f81f"
+
+DESCRIPTION="An automated testing system for bash"
+HOMEPAGE="https://github.com/sstephenson/bats/"
+SRC_URI="https://github.com/sstephenson/bats/archive/${COMMITHASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/bats-${COMMITHASH}"
+
+src_test() {
+ bin/bats --tap test || die "Tests failed"
+}
+
+src_install() {
+ exeinto /usr/libexec/bats
+ doexe libexec/*
+ dosym ../libexec/bats/bats /usr/bin/bats
+
+ dodoc README.md
+ doman man/bats.1 man/bats.7
+}