summaryrefslogtreecommitdiff
path: root/dev-util/bear/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-13 05:50:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-13 05:50:34 +0100
commit4b718beb7d5fd4e0b5d741ff3a4c5c570519195e (patch)
treeeb9b412ce4b9457ccbb2a6481d80e5f407fdd499 /dev-util/bear/files
parent241157fae4eae88cefc48b4644bad8b9e53583dc (diff)
gentoo auto-resync : 13:05:2023 - 05:50:34
Diffstat (limited to 'dev-util/bear/files')
-rw-r--r--dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch b/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch
new file mode 100644
index 000000000000..7c8425e46ede
--- /dev/null
+++ b/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch
@@ -0,0 +1,26 @@
+BUG: https://bugs.gentoo.org/906082
+UPSTREAM: https://github.com/rizsotto/Bear/pull/526
+
+From 46a032fa0fc8131779ece13f26735ec84be891e8 Mon Sep 17 00:00:00 2001
+From: jinqiang zhang <peeweep@0x0.ee>
+Date: Thu, 11 May 2023 03:33:17 +0800
+Subject: [PATCH] dependency: fix fmt 10.0.0 incompatibilities (#526)
+
+Signed-off-by: jinqiang zhang <peeweep@0x0.ee>
+---
+ source/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt
+index 6da1131f..fe6b710b 100644
+--- a/source/CMakeLists.txt
++++ b/source/CMakeLists.txt
+@@ -29,7 +29,7 @@ find_package(spdlog REQUIRED)
+ find_package(PkgConfig REQUIRED)
+ pkg_check_modules(gRPC REQUIRED IMPORTED_TARGET protobuf grpc++)
+
+-if (fmt_VERSION_MAJOR EQUAL 9)
++if (fmt_VERSION_MAJOR GREATER_EQUAL 9)
+ set(FMT_NEEDS_OSTREAM_FORMATTER 1)
+ set(HAVE_FMT_STD_H 1) # FIXME: this should be done with `check_include_file`
+ endif ()