summaryrefslogtreecommitdiff
path: root/dev-util/bin_replace_string/bin_replace_string-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/bin_replace_string/bin_replace_string-0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/bin_replace_string/bin_replace_string-0.2.ebuild')
-rw-r--r--dev-util/bin_replace_string/bin_replace_string-0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/bin_replace_string/bin_replace_string-0.2.ebuild b/dev-util/bin_replace_string/bin_replace_string-0.2.ebuild
new file mode 100644
index 000000000000..d51ab7696095
--- /dev/null
+++ b/dev-util/bin_replace_string/bin_replace_string-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="A tool to edit C strings in compiled binaries"
+HOMEPAGE="http://ohnopub.net/~ohnobinki/bin_replace_string"
+SRC_URI="ftp://mirror.ohnopub.net/mirror/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc"
+
+RDEPEND="virtual/libelf:0"
+DEPEND="doc? ( app-text/txt2man )
+ ${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc)
+ )
+
+ autotools-utils_src_configure
+}