summaryrefslogtreecommitdiff
path: root/dev-util/bloaty/bloaty-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
commitd51fe7680c5270ddf8d324bbe11caab6d1e27ade (patch)
treea895b5889d79dbbb9aa52995fcac4816acfa07c1 /dev-util/bloaty/bloaty-9999.ebuild
parent7d52991b5dce3a07be15d3cbbf06abb3fc08cb9c (diff)
gentoo auto-resync : 21:08:2023 - 21:44:47
Diffstat (limited to 'dev-util/bloaty/bloaty-9999.ebuild')
-rw-r--r--dev-util/bloaty/bloaty-9999.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/dev-util/bloaty/bloaty-9999.ebuild b/dev-util/bloaty/bloaty-9999.ebuild
index 4aa412ab17d3..e8c0b98fe27a 100644
--- a/dev-util/bloaty/bloaty-9999.ebuild
+++ b/dev-util/bloaty/bloaty-9999.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
DESCRIPTION="A size profiler for binaries"
HOMEPAGE="https://github.com/google/bloaty"
-LICENSE="Apache-2.0"
-SLOT="0"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -17,27 +15,39 @@ if [[ ${PV} == 9999 ]]; then
RESTRICT="!test? ( test )"
else
SRC_URI="https://github.com/google/${PN}/releases/download/v${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64"
fi
+LICENSE="Apache-2.0"
+SLOT="0"
+
BDEPEND="
virtual/pkgconfig
"
DEPEND="
+ dev-cpp/abseil-cpp:=
dev-libs/capstone:=
dev-libs/protobuf:=
dev-libs/re2:=
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-system-abseil.patch
+)
+
src_configure() {
local mycmakeargs=(
-DBLOATY_ENABLE_CMAKETARGETS=OFF
+ -DBUILD_SHARED_LIBS=OFF
)
+
if [[ ${PV} == 9999 ]]; then
mycmakeargs+=(
-DBUILD_TESTING=$(usex test)
+ $(usex test -DINSTALL_GTEST=OFF "")
)
fi
+
cmake_src_configure
}