summaryrefslogtreecommitdiff
path: root/dev-util/blueprint-compiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-23 06:45:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-23 06:45:02 +0000
commitc78477d222e1ceb9516a9bbbadbba0b5c1ce11db (patch)
tree5187cbad4740387edb2c1cca0942036a0fdccd88 /dev-util/blueprint-compiler
parent564687d289b862b8b079569a45a2d39d7b8c3585 (diff)
gentoo auto-resync : 23:01:2025 - 06:45:02
Diffstat (limited to 'dev-util/blueprint-compiler')
-rw-r--r--dev-util/blueprint-compiler/Manifest4
-rw-r--r--dev-util/blueprint-compiler/blueprint-compiler-0.14.0.ebuild8
-rw-r--r--dev-util/blueprint-compiler/blueprint-compiler-0.16.0.ebuild83
3 files changed, 93 insertions, 2 deletions
diff --git a/dev-util/blueprint-compiler/Manifest b/dev-util/blueprint-compiler/Manifest
index 4d5eb7fb256e..7c9ce807d7a3 100644
--- a/dev-util/blueprint-compiler/Manifest
+++ b/dev-util/blueprint-compiler/Manifest
@@ -1,3 +1,5 @@
DIST blueprint-compiler-v0.14.0.tar.bz2 95515 BLAKE2B e5e4c721f76a9455d0f53b54e5b981cbd918959c206cad2b6fa47ba3a85bb1bcacb11d65b848cbde01ae32faa6f09c1f80cf6150ee436e359e7b1e9044822bb4 SHA512 3c2c422c6c41c408aff2b4342186e7a20eeb37489aff396d48c936f7a856e9d946f3d6fb6ad64a0fd933bdfc6bce546571d67c95b8f01af591c562d531c246c0
-EBUILD blueprint-compiler-0.14.0.ebuild 1447 BLAKE2B 2815d09f115797304ff10b15c870c8f095b8d109bc929cb480f945ec30689337a0525b94ef635428f702471ca8df7857e1d00629d0b00e0daea95b99dad5ec98 SHA512 c3623d8bd74c24efb732f7a931191b65e9013ff0a0258cb03caad9cbff81cf17afccbd1ab8699edecbaee30ecfa818cbe78ccb8596dd2c7aaafc1db27fe76e39
+DIST blueprint-compiler-v0.16.0.tar.bz2 101391 BLAKE2B 6380f3aa3472ab0567e89acadf290e4954dbe640d5c4aaa6adfe3fb13ee50295c21dffcca1a4baccf3b5049429eae22d8953acc65dbef1904de01209226d0c88 SHA512 9c8b3da532f7d9a36fa0993da295438afe57a5da03e122f3d9cc715dd7b7d99f2be52416f19a7a8d8523516f4f799cbb0a2c9ffafdef58a66163857542e5c8d7
+EBUILD blueprint-compiler-0.14.0.ebuild 1539 BLAKE2B 8447d9f19a6a406c27d3b1c66e012bf218f1d7dbe3d4d0407c73a27bbad442c30b8448f665fe10037d66fde948f86026d78c7d44330dde10294fcea20873dc12 SHA512 e05b6c69322e0dbc985f1ac9c42852dfe2acb8d7bf52a98b628271c8e3fa1a04d9677db25ee69609da797e80d207e82180da37ec37f4fe9b38d32501fc8c70cf
+EBUILD blueprint-compiler-0.16.0.ebuild 1611 BLAKE2B 444dbb2131a36f492b2224bd56d4816c3ca38a1a8b7609e11f88cc54795941fea1a91c860328dab775659abb7f8648a051492cac5de5773e1c34740b940b3fec SHA512 a5b2453bb0b8d8f53a99ce8aa05134dc638c2bd84aad81ab91635c82c5059504ab333ff20d644990082c855a4ff1c3757fef26ebf7d9df903599e120b8b23443
MISC metadata.xml 906 BLAKE2B 8426e8a64268f0c3310028be81cc727a63ddd67df842d59eae80c55b12c41f446107cc61ed11c115da8b4cc9a67bb16b1d5c9dc09e541f41901eac29611f3e9d SHA512 3af397704e2717cbba16c890af04066cd67f40c1cc477429d3c53b713c079101036a17e788c0f5e316799cbfc8329356686ad129bfbed409002d96df3159d480
diff --git a/dev-util/blueprint-compiler/blueprint-compiler-0.14.0.ebuild b/dev-util/blueprint-compiler/blueprint-compiler-0.14.0.ebuild
index 0627fff78fe8..f9358c0dc79a 100644
--- a/dev-util/blueprint-compiler/blueprint-compiler-0.14.0.ebuild
+++ b/dev-util/blueprint-compiler/blueprint-compiler-0.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -50,6 +50,12 @@ BDEPEND="
DOCS=( CONTRIBUTING.md MAINTENANCE.md NEWS.md README.md )
+src_prepare() {
+ default
+
+ rm ./tests/test_samples.py || die # Fails on CI, bug #947156
+}
+
src_configure() {
local -a emesonargs=(
$(meson_use doc docs)
diff --git a/dev-util/blueprint-compiler/blueprint-compiler-0.16.0.ebuild b/dev-util/blueprint-compiler/blueprint-compiler-0.16.0.ebuild
new file mode 100644
index 000000000000..0bad00ef063f
--- /dev/null
+++ b/dev-util/blueprint-compiler/blueprint-compiler-0.16.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit edo meson python-single-r1 virtualx
+
+DESCRIPTION="Compiler for Blueprint, a markup language for GTK user interfaces"
+HOMEPAGE="https://jwestman.pages.gitlab.gnome.org/blueprint-compiler/
+ https://gitlab.gnome.org/jwestman/blueprint-compiler/"
+
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gnome.org/jwestman/${PN}.git"
+else
+ SRC_URI="https://gitlab.gnome.org/jwestman/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}/${PN}-v${PV}"
+
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/furo[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+ )
+ test? (
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ )
+"
+
+DOCS=( CONTRIBUTING.md MAINTENANCE.md NEWS.md README.md )
+
+src_prepare() {
+ default
+
+ rm ./tests/test_deprecations.py || die
+ rm ./tests/test_samples.py || die # Fails on CI, bug #947156
+}
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_use doc docs)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+
+ if use doc ; then
+ build_sphinx docs
+ fi
+}
+
+src_test() {
+ virtx edo "${EPYTHON}" -m unittest
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}/usr/bin"
+ python_optimize
+}