summaryrefslogtreecommitdiff
path: root/dev-util/breakpad/breakpad-2023.01.27.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-21 00:05:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-21 00:05:36 +0100
commitbfd63d5b0e96ad32e0d0a8fe15512b6a9ac6fc9e (patch)
tree4d1f8172a8137960573865b4a5ac8b7846d281df /dev-util/breakpad/breakpad-2023.01.27.ebuild
parent77b275a53383b07b154caa09feb6f4961b206638 (diff)
gentoo auto-resync : 21:05:2024 - 00:05:35
Diffstat (limited to 'dev-util/breakpad/breakpad-2023.01.27.ebuild')
-rw-r--r--dev-util/breakpad/breakpad-2023.01.27.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-util/breakpad/breakpad-2023.01.27.ebuild b/dev-util/breakpad/breakpad-2023.01.27.ebuild
index 398f79e86f23..f577690b56e5 100644
--- a/dev-util/breakpad/breakpad-2023.01.27.ebuild
+++ b/dev-util/breakpad/breakpad-2023.01.27.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/google/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="BSD BSD-4"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="test"
+IUSE="test tools"
RDEPEND="
net-misc/curl
@@ -24,6 +24,7 @@ DEPEND="${RDEPEND}
"
BDEPEND="test? ( dev-cpp/gtest )"
RESTRICT="!test? ( test )"
+REQUIRED_USE="elibc_musl? ( !tools )"
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
@@ -51,5 +52,6 @@ src_prepare() {
src_configure() {
econf \
--enable-system-test-libs \
+ $(use_enable tools) \
|| die
}