summaryrefslogtreecommitdiff
path: root/dev-util/bugbite-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-09 03:03:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-09 03:03:12 +0000
commit2be329ae14bbf99f0fc4de7567e2386bbb529fdc (patch)
tree99e1d21f40429392d5eb255ec008fdd96e4fa284 /dev-util/bugbite-cli
parent2cd9ff612e84f0c1ef63c9e9e13be53fe576cc2b (diff)
gentoo auto-resync : 09:11:2024 - 03:03:12
Diffstat (limited to 'dev-util/bugbite-cli')
-rw-r--r--dev-util/bugbite-cli/Manifest4
-rw-r--r--dev-util/bugbite-cli/bugbite-cli-0.0.13.ebuild55
-rw-r--r--dev-util/bugbite-cli/metadata.xml3
3 files changed, 61 insertions, 1 deletions
diff --git a/dev-util/bugbite-cli/Manifest b/dev-util/bugbite-cli/Manifest
index f46e09b4bd0b..192fe63e32e4 100644
--- a/dev-util/bugbite-cli/Manifest
+++ b/dev-util/bugbite-cli/Manifest
@@ -1,3 +1,5 @@
DIST bugbite-cli-0.0.12.tar.xz 21202148 BLAKE2B dd7d7b0927741d77b3a724273360348558fc2675e22e948f2f9e2b418db6a263986e051ebb700094610e98021af6264288ebcbe271c0efac88c8091f9cd0725e SHA512 2056450d13ccbdf484ef2f4e4ea663a4f10fbd4222574e630510a85a0d10b2c939e9250be947b3bd1ea3a43a78f946b6e142db94f650aab0cd46db910f369411
+DIST bugbite-cli-0.0.13.tar.xz 22286212 BLAKE2B c906446a89ae2c7346318cffb96c93178585ef42589bba4df4ecdf906e8890a922324d484bbd252e119a8d47370c63816dfb0a55481586de6f30f13d7d3d84bc SHA512 40971032ff4e63416c3383a55418ba7c0c4c85321caace435000018da93176b6b1d83ee04aa4abdfa31646c9b6d1777c9e5acb035b14bca210bfc22ffc7fd90d
EBUILD bugbite-cli-0.0.12.ebuild 1320 BLAKE2B c0be4457f98b153cb84a21e4f5c00c59f9014985c872fb7e893d0b16e8981afe75603e987286aac4118e10eca60bacdbe6896b8cfa1a58720b0e1143142a6397 SHA512 a87a1bb4f5e53f5a299ed4843e425bc349c3446b3ee395d6531c25d156a1d8921f07e253147bfab1308c1aaf94950986c93a20b06b29130a8986426fda3ce0ff
-MISC metadata.xml 493 BLAKE2B 99fd8405920676653bbb75a4d71b81789d03638b4ad3970a23d3335c9af73fad4947000f40f6a211fc3ab9e1362d5cd19eeb26d80e93bc8d0838fdddaf179ed9 SHA512 5ad93bfef807b5d88adec2773e6496a4462f7e000ac15d4d4e7ea9b0646d530290bd9d7be23de31c5bfd33e352b2ea66fc3937ef417ffcc93232842132db3b6d
+EBUILD bugbite-cli-0.0.13.ebuild 1497 BLAKE2B 28f3c1482ffa835312b1953a25c4d043d1535942e42cc56025d7c563d78259fc1418172e39e93a4574090574e6573e062d3a858d1ba8487f93b763a3d546f6f2 SHA512 152bcc814f2091e2c215867ee60c9388721691629fceb108950032e0996065d6aeb306c424c45cd7ac77132b4d23f759d3579dfe56654136aca9e00c707e9406
+MISC metadata.xml 590 BLAKE2B b31588e873fa47581c84c163e00685ee3cd91cb6dea21ac265bbf7a4f4e6ec729414b71ce90d73abd4fd3b4342f751729c9115a2c614a856042047cde0b1bf03 SHA512 721e0da0a31e627e29bdc9ac92bafcdca54b04ff5be4cf08ad0f56154fe43df5acec46d4963773636353fcd6e2c469072aace4b33fda6df151034728106c0a90
diff --git a/dev-util/bugbite-cli/bugbite-cli-0.0.13.ebuild b/dev-util/bugbite-cli/bugbite-cli-0.0.13.ebuild
new file mode 100644
index 000000000000..dacf74522b2c
--- /dev/null
+++ b/dev-util/bugbite-cli/bugbite-cli-0.0.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cargo edo shell-completion
+
+DESCRIPTION="A command line tool for bug, issue, and ticket mangling"
+HOMEPAGE="https://github.com/radhermit/bugbite"
+SRC_URI="https://github.com/radhermit/bugbite/releases/download/${P}/${P}.tar.xz"
+LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="openssl static test"
+RESTRICT="!test? ( test ) "
+
+BDEPEND="
+ >=virtual/rust-1.80
+ openssl? (
+ !static? ( dev-libs/openssl:= )
+ static? ( dev-libs/openssl:=[static-libs] )
+ )
+ test? ( dev-util/cargo-nextest )
+"
+
+QA_FLAGS_IGNORED="usr/bin/bite"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use static ; then
+ local rust_target=$( rustc -vV 2>/dev/null | sed -n 's|^host: ||p' )
+ [[ -z ${rust_target} ]] && die "Failed to read host target from rustc!"
+ export RUSTFLAGS="-C target-feature=+crt-static ${RUSTFLAGS}"
+ export static_stuff="--target ${rust_target}"
+ fi
+}
+
+src_configure() {
+ local myfeatures=(
+ $(usev openssl native-tls)
+ )
+ cargo_src_configure --no-default-features ${static_stuff}
+}
+
+src_test() {
+ edo cargo nextest run $(usev !debug '--release') --color always --features test --tests ${static_stuff}
+}
+
+src_install() {
+ cargo_src_install
+
+ doman man/*
+ dofishcomp shell/bite.fish
+ dozshcomp shell/_bite
+ newbashcomp shell/bite.bash bite
+}
diff --git a/dev-util/bugbite-cli/metadata.xml b/dev-util/bugbite-cli/metadata.xml
index e71a8c41c9c8..1b88e6c112b7 100644
--- a/dev-util/bugbite-cli/metadata.xml
+++ b/dev-util/bugbite-cli/metadata.xml
@@ -13,4 +13,7 @@
<upstream>
<remote-id type="github">radhermit/bugbite</remote-id>
</upstream>
+ <use>
+ <flag name="openssl">Use <pkg>dev-libs/openssl</pkg> as a crypto backend</flag>
+ </use>
</pkgmetadata>