summaryrefslogtreecommitdiff
path: root/dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 11:49:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 11:49:23 +0000
commit840a65e2af3f2cc7527e723a28f6e627a9592fb7 (patch)
tree66e124d9e55317fe43e1af9984e75c156df5cb29 /dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild
parent73e3b099187df1c4f2df056e45f345a56d2535aa (diff)
gentoo auto-resync : 30:01:2024 - 11:49:23
Diffstat (limited to 'dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild')
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild
new file mode 100644
index 000000000000..35f5e4f31f26
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-pkg/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+RESTRICT="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -e "/version/s/=.*$/=\"${PV/_p/.post}\",/" -i setup.py || die
+ distutils-r1_src_prepare
+}