summaryrefslogtreecommitdiff
path: root/dev-util/cargo-ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-10 03:03:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-10 03:03:09 +0000
commitbe94ae04eee564451203d45977c2ef7c7ace1580 (patch)
tree616ffc0ad9aee18dc7d5e9e62bf62394e8e520ba /dev-util/cargo-ebuild
parent2be329ae14bbf99f0fc4de7567e2386bbb529fdc (diff)
gentoo auto-resync : 10:11:2024 - 03:03:09
Diffstat (limited to 'dev-util/cargo-ebuild')
-rw-r--r--dev-util/cargo-ebuild/Manifest2
-rw-r--r--dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r2.ebuild (renamed from dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r1.ebuild)12
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-util/cargo-ebuild/Manifest b/dev-util/cargo-ebuild/Manifest
index 79e43a016eda..fc129f556ce9 100644
--- a/dev-util/cargo-ebuild/Manifest
+++ b/dev-util/cargo-ebuild/Manifest
@@ -126,5 +126,5 @@ DIST winapi-0.3.9.crate 1200382 BLAKE2B cb5799749ccd935ea2d7068d953cecf19f543d9d
DIST winapi-i686-pc-windows-gnu-0.4.0.crate 2918815 BLAKE2B 4d357e4d30f9552972170d65b9a5358b69c46a3e772fe05efc22f3d4ffc1caeeaad7aacdc7abd503a7ad0545f8bd7d22bf351dcb6df76f812fa4d45c34d65df0 SHA512 a672ccefd0730a8166fef1d4e39f9034d9ae426a3f5e28d1f4169fa5c5790767693f281d890e7804773b34acdb0ae1febac33cde8c50c0044a5a6152c7209ec2
DIST winapi-util-0.1.5.crate 10164 BLAKE2B fc800aceae5249a858c806c3e969ef2545766099872d856ebee51c883d9acf1122278db9607d50ca53eac351502b700fd2463900932d342240f97f683d517963 SHA512 7baeb661f397c4693dfa001fdc774b323c51a7c55caad40f2de5112a1cefd1d6151e3df41fa4ee193460a5905917c83d2b1de5fa10b4bd014ad96690af95c0fd
DIST winapi-x86_64-pc-windows-gnu-0.4.0.crate 2947998 BLAKE2B 2ad1ea8b5fa07d544e910ccba043ae925269b76b26c9da356305b34b86741dd8b9aff0b9ffe3d562db4fcd7d7c46a11ce9e3168b782b1d89ae6881742b7ede82 SHA512 4a654af6a5d649dc87e00497245096b35a2894ae66f155cb62389902c3b93ddcc5cf7d0d8b9dd97b291d2d80bc686af2298e80abef6ac69883f4a54e79712513
-EBUILD cargo-ebuild-0.5.4-r1.ebuild 3426 BLAKE2B 5520739f0cac8d519b4c964f7f45836f14cd6af5944a26e2a7fc3a18e1c72ef940655d98750ceb000d757f04311a0e17afeffca298f97f0864e00589f582828d SHA512 4406acf838a67428c58789519f8aca85722d2fb24f09c4ae9e8072c1333d4dcb99f84c405d18f852876e6ee418a2f544fc23a23b5c458a869ede8045b5a80cd8
+EBUILD cargo-ebuild-0.5.4-r2.ebuild 3608 BLAKE2B fe4e923dd7125bbca60934239bcad0c1d4df1bcfe6c2b00539363a3f24d7cbb6fda263192e8eb1c50afbfc9cc84a7ed888adf1426bc9a158431c602f2601efce SHA512 f9d4e1120b5439c8aa3498f5c5d4e98c5e1ae2de0c98fe2f863cb1dba2044ee049ab22906fccbf6215cff6fb795881f90466ff35902941926e9595461e0b308e
MISC metadata.xml 358 BLAKE2B f56569b1f9e424641ca562cb068c696d27e5819953a7671ef2db1447c82d4bc039e4d09c4090a605191e510f3c3bb27bb5993b8ae954d2838a36d8b49ade3141 SHA512 9a66eb8bba4803fdbc8dd1c39acce838ed9158a8e2e5db4bf48452c6ecf5062c8a7a04916945d44493a440fe96a1ebae93ec44c6bef925e60b12520413059669
diff --git a/dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r1.ebuild b/dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r2.ebuild
index a2c1374def5e..990d4d5893a5 100644
--- a/dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r1.ebuild
+++ b/dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017-2023 Gentoo Authors
+# Copyright 2017-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Auto-Generated by cargo-ebuild 0.5.4-r1
@@ -134,6 +134,9 @@ CRATES="
winapi-x86_64-pc-windows-gnu@0.4.0
"
+# https://github.com/rust-lang/rust/issues/113152#issuecomment-1612578376
+RUST_MAX_VER="1.71.1"
+
inherit cargo
DESCRIPTION="Generates an ebuild for a package using the in-tree eclasses."
@@ -156,7 +159,6 @@ DEPEND="
RDEPEND="
${DEPEND}
- virtual/rust
"
PATCHES=(
@@ -165,6 +167,12 @@ PATCHES=(
QA_FLAGS_IGNORED="usr/bin/cargo-ebuild"
+pkg_setup() {
+ rust_pkg_setup
+ # Requires nightly feature proc-macro2
+ export RUSTC_BOOTSTRAP=1
+}
+
src_configure() {
export LIBGIT2_SYS_USE_PKG_CONFIG=1 LIBSSH2_SYS_USE_PKG_CONFIG=1 PKG_CONFIG_ALLOW_CROSS=1
cargo_src_configure