summaryrefslogtreecommitdiff
path: root/dev-util/checkbashisms/checkbashisms-2.23.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-20 07:07:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-20 07:07:08 +0100
commitaaa44376d7162304219748a3b6771d9a26fc80fe (patch)
tree62d3e3eea5cc8134a92a731a756d15bfd8fe0177 /dev-util/checkbashisms/checkbashisms-2.23.5.ebuild
parent6f97f3b697516aeae25033ec37234739fff23fbc (diff)
gentoo auto-resync : 20:07:2023 - 07:07:07
Diffstat (limited to 'dev-util/checkbashisms/checkbashisms-2.23.5.ebuild')
-rw-r--r--dev-util/checkbashisms/checkbashisms-2.23.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/checkbashisms/checkbashisms-2.23.5.ebuild b/dev-util/checkbashisms/checkbashisms-2.23.5.ebuild
new file mode 100644
index 000000000000..c8583d535c82
--- /dev/null
+++ b/dev-util/checkbashisms/checkbashisms-2.23.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="devscripts"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
+HOMEPAGE="https://packages.debian.org/devscripts https://salsa.debian.org/debian/devscripts"
+SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_P/-/_}.tar.xz"
+S="${WORKDIR}/${MY_PN}/scripts"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# Requires python packages to check tools we don't need anyway
+RESTRICT="test"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+src_prepare() {
+ default
+
+ sed "s@###VERSION###@${PV}@" -i checkbashisms.pl || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ doman ${PN}.1
+}