summaryrefslogtreecommitdiff
path: root/dev-util/coccigrep
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/coccigrep
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/coccigrep')
-rw-r--r--dev-util/coccigrep/Manifest4
-rw-r--r--dev-util/coccigrep/coccigrep-1.13.ebuild60
-rw-r--r--dev-util/coccigrep/files/50coccigrep-gentoo.el4
-rw-r--r--dev-util/coccigrep/metadata.xml14
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-util/coccigrep/Manifest b/dev-util/coccigrep/Manifest
new file mode 100644
index 000000000000..db891843f02f
--- /dev/null
+++ b/dev-util/coccigrep/Manifest
@@ -0,0 +1,4 @@
+AUX 50coccigrep-gentoo.el 99 BLAKE2B 596f01a6ac85deca70bdcf4f50c2475c7a38e44926d719e0da5eb23a8c713f89ebad0182cdca66b3011029bcda14d0cde76d4a186a126e05b74a0ccaa8e9efd1 SHA512 13cf90c99017cfb865c1d41e9813bb20993b4a91419e4bcca6b5536e8c35bfb871616c5174dd08eb8f1726f05296205428d14eaf9e9fabcf08bff01b287581f4
+DIST coccigrep-1.13.tar.gz 32366 BLAKE2B 8b9d8e0832c6bbacb3a8efd74ab8f4a0ec3112e935ddca63f345799ebc96a3dfbc8fe8e9fa77cee912d7dd5ee28c62e72ea00173e4ee4b16588b4b6e1eaf661c SHA512 d01baefe1c5f5d23ce03e5daccde0c38d4c05872313a0c8d15e53444c34fa6ae0db3b25bd62d8635a3f7b16e64767f92051c59d29bbd81cd24f94c9376af08ba
+EBUILD coccigrep-1.13.ebuild 1336 BLAKE2B 7f096b29a8b9556a20b0253ec4016c21f15da1cc51d71dbb15057d0ae890e92d1b7b92d9c728520780ccb4a8b7602cfc6ac9bd45b0e6031d483e9483d0774aa6 SHA512 e8c7b1e718a98695eea59a7a76920c6e97b5967aaa0f961d76063f5d049dc687f274fc2c3fb3d34ba0ee090a07ff7d6dabd105682754a4211c4c0530a7a58de4
+MISC metadata.xml 400 BLAKE2B b233da69d5a9b48dc8349f1f0e746a5d39dbf14a2da934b486935e44d5a8219d7e771f880ce41d2005b2ccc75f5c982989008e7b294bb853d1e240203fb83d32 SHA512 785b3ffe7af1ca248f1aad24c21e3d5c5e0fdef899a7002ae53fea4a8fcafd3ad2d2e759540a1e0556853b62bfa7b0c27303a5be45bde5ce176db3be94c31c40
diff --git a/dev-util/coccigrep/coccigrep-1.13.ebuild b/dev-util/coccigrep/coccigrep-1.13.ebuild
new file mode 100644
index 000000000000..f56d4bacedc9
--- /dev/null
+++ b/dev-util/coccigrep/coccigrep-1.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 elisp-common
+
+DESCRIPTION="A semantic grep for the C language"
+HOMEPAGE="http://home.regit.org/software/coccigrep/"
+SRC_URI="https://github.com/regit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs vim"
+
+RDEPEND="dev-util/coccinelle[python]
+ emacs? ( virtual/emacs )
+ vim? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="doc? ( dev-python/sphinx )
+ emacs? ( virtual/emacs )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+python_compile_all() {
+ use doc && emake -C doc html
+
+ if use emacs ; then
+ elisp-compile editors/*.el || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS="doc/_build/html/."
+ distutils-r1_python_install_all
+
+ doman ${PN}.1
+
+ if use emacs ; then
+ elisp-install ${PN} editors/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+
+ if use vim ; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins editors/cocci-grep.vim
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ einfo "Syntax highlighting is supported through dev-python/pygments."
+ einfo "Install it if you want colorized output formats."
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/coccigrep/files/50coccigrep-gentoo.el b/dev-util/coccigrep/files/50coccigrep-gentoo.el
new file mode 100644
index 000000000000..7fbc6b93e541
--- /dev/null
+++ b/dev-util/coccigrep/files/50coccigrep-gentoo.el
@@ -0,0 +1,4 @@
+;;; coccigrep site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(require 'cocci-grep)
diff --git a/dev-util/coccigrep/metadata.xml b/dev-util/coccigrep/metadata.xml
new file mode 100644
index 000000000000..0c548f25bb2b
--- /dev/null
+++ b/dev-util/coccigrep/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <use>
+ <flag name="vim">Install the coccigrep vim plugin</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">regit/coccigrep</remote-id>
+ </upstream>
+</pkgmetadata>