summaryrefslogtreecommitdiff
path: root/dev-util/codespell/codespell-2.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-25 06:49:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-25 06:49:35 +0000
commit0b82ae29b3034efe3e7b7f533dbcb76168544c5e (patch)
treeea954d341afdcf53b3b79c78c9a54ff2c9693096 /dev-util/codespell/codespell-2.2.4.ebuild
parentb0b85e141f6a9a74d9d6bdce989a626ff5e92523 (diff)
gentoo auto-resync : 25:03:2023 - 06:49:35
Diffstat (limited to 'dev-util/codespell/codespell-2.2.4.ebuild')
-rw-r--r--dev-util/codespell/codespell-2.2.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/codespell/codespell-2.2.4.ebuild b/dev-util/codespell/codespell-2.2.4.ebuild
new file mode 100644
index 000000000000..f2af4c1fbbbc
--- /dev/null
+++ b/dev-util/codespell/codespell-2.2.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Check text files for common misspellings"
+HOMEPAGE="https://pypi.org/project/codespell https://github.com/codespell-project/codespell"
+
+# Code licensed under GPL-2, dictionary licensed under CC-BY-SA-3.0
+LICENSE="GPL-2 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.4-drop-coverage.patch )
+
+distutils_enable_tests pytest