summaryrefslogtreecommitdiff
path: root/dev-util/cppunit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-23 19:24:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-23 19:24:10 +0000
commit575bcb9220287a6f0d2577db1fd9fe55d9d8b745 (patch)
tree52f12cfa140d4839d32305dd42eebe34e9686234 /dev-util/cppunit
parent4c5bd80830992553e02f099442277e10ee97372d (diff)
gentoo auto-resync : 23:02:2025 - 19:24:09
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/Manifest3
-rw-r--r--dev-util/cppunit/cppunit-1.15.1_p20240106.ebuild79
-rw-r--r--dev-util/cppunit/cppunit-9999.ebuild75
3 files changed, 157 insertions, 0 deletions
diff --git a/dev-util/cppunit/Manifest b/dev-util/cppunit/Manifest
index 9bb124326427..8a785f8bd50a 100644
--- a/dev-util/cppunit/Manifest
+++ b/dev-util/cppunit/Manifest
@@ -1,3 +1,6 @@
+DIST cppunit-1.15.1-patches.tar.xz 17456 BLAKE2B 1520804f91912426302f61b125d1ed669eef58e00f1c4d35984b277656b72362bd2b4b76d77ea44780c74d142dd9d768dbaccf0a833f8e42ee0b03662ccada27 SHA512 1094c386196c43e1f6de08470b2d949a8f16b70e01028c061dc1b96d836d272fa17a3189b22113a0bd654712424168e7a9ca6bc0be853c7a3e2fe1061bfeb2d5
DIST cppunit-1.15.1.tar.gz 814363 BLAKE2B a1d1d1ee9b6ef408843a6e989a37653944ad85069b4896f18d0f01410acebf7342f70e8c031e58f7ad0e686a85869d521906816e0f0b1762d238efb606cb7310 SHA512 0feb47faec451357bb4c4e287efa17bb60fd3ad966d5350e9f25b414aaab79e94921024b0c0497672f8d3eeb22a599213d2d71d9e1d28b243b3e37f3a9a43691
EBUILD cppunit-1.15.1-r3.ebuild 1344 BLAKE2B 74bd49fb2bce204ab605f45a984e0aa13145e8b8bb917b9232af32400b89a4a013d3929b01850a0a41709504c4ddc34adf7e5e992291c574c61815aa8b1b3924 SHA512 98a6c2ba4f93f254111a7275a21dd38f8ffaccd5c1cbbd0b2299a16d6ad7a24ef73641f8c892cf918f2170807b3bf3cc609fb11ceebd0efb4e07bcd0d87f3b1b
+EBUILD cppunit-1.15.1_p20240106.ebuild 1735 BLAKE2B 393581981c16cc0b19ef7da8c6c0e33e247a4044408191756271de669b1869d6c2f4213940fd2f5cbc7c6ca80c80f62f8ecf6d7cf32c0022251e965a8408fbe1 SHA512 b029cb5133c6fb58c9921e8123744c8f36001a5287ed60db45793bfe0276775e2e6621df105c3dc554026eb8856bd335d58d849f53a111ddf40e72b22a114d75
+EBUILD cppunit-9999.ebuild 1690 BLAKE2B a7b6b2d14e846ce92e9f5152c5d927f3498de430db6e2983bb86d50ec65866bab919782e559de8dfebddbd5f3f8390ce7f125c1d5b381c724afe1bec081f95e5 SHA512 9559c43345007980db346efdce9d8f1bb4cf92b6694e7a2e859e0e78cace77d253b59438259cc99028f58a538f0985492a5e3c959c5ff2ba4c3deb08fc4d1d8e
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/dev-util/cppunit/cppunit-1.15.1_p20240106.ebuild b/dev-util/cppunit/cppunit-1.15.1_p20240106.ebuild
new file mode 100644
index 000000000000..3be3e5bdd5a2
--- /dev/null
+++ b/dev-util/cppunit/cppunit-1.15.1_p20240106.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic multilib-minimal
+
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
+else
+ SRC_URI="
+ https://dev-www.libreoffice.org/src/${P%%_p*}.tar.gz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P%%_p*}-patches.tar.xz
+ "
+ S="${WORKDIR}"/${P%%_p*}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/1.15"
+IUSE="doc examples"
+
+BDEPEND="
+ doc? (
+ app-text/doxygen[dot]
+ media-gfx/graphviz
+ )
+"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO ChangeLog doc/FAQ )
+
+PATCHES=(
+ "${WORKDIR}"/${P%%_p*}-patches
+)
+
+src_prepare() {
+ default
+
+ # Needed for snapshot
+ eautoreconf
+}
+
+src_configure() {
+ # Anything else than -O0 breaks on alpha
+ use alpha && replace-flags "-O?" -O0
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(multilib_native_use_enable doc dot)
+ $(multilib_native_use_enable doc doxygen)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ if use doc ; then
+ mv "${ED}"/usr/share/${PN}/html "${ED}"/usr/share/doc/${PF} \
+ || die
+ rm -r "${ED}"/usr/share/${PN} || die
+ fi
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use examples ; then
+ find examples -iname "*.o" -delete
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}
diff --git a/dev-util/cppunit/cppunit-9999.ebuild b/dev-util/cppunit/cppunit-9999.ebuild
new file mode 100644
index 000000000000..675991b4bcd6
--- /dev/null
+++ b/dev-util/cppunit/cppunit-9999.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic multilib-minimal
+
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
+else
+ SRC_URI="
+ https://dev-www.libreoffice.org/src/${P%%_p*}.tar.gz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P%%_p*}-patches.tar.xz
+ "
+ S="${WORKDIR}"/${P%%_p*}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/1.15"
+IUSE="doc examples"
+
+BDEPEND="
+ doc? (
+ app-text/doxygen[dot]
+ media-gfx/graphviz
+ )
+"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO ChangeLog doc/FAQ )
+
+src_prepare() {
+ default
+
+ # Needed for snapshot
+ eautoreconf
+}
+
+src_configure() {
+ # Anything else than -O0 breaks on alpha
+ use alpha && replace-flags "-O?" -O0
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(multilib_native_use_enable doc dot)
+ $(multilib_native_use_enable doc doxygen)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ if use doc ; then
+ mv "${ED}"/usr/share/${PN}/html "${ED}"/usr/share/doc/${PF} \
+ || die
+ rm -r "${ED}"/usr/share/${PN} || die
+ fi
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use examples ; then
+ find examples -iname "*.o" -delete
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}