summaryrefslogtreecommitdiff
path: root/dev-util/cpputest/cpputest-4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-util/cpputest/cpputest-4.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-util/cpputest/cpputest-4.0.ebuild')
-rw-r--r--dev-util/cpputest/cpputest-4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/cpputest/cpputest-4.0.ebuild b/dev-util/cpputest/cpputest-4.0.ebuild
new file mode 100644
index 000000000000..a3cf73658e60
--- /dev/null
+++ b/dev-util/cpputest/cpputest-4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Unit testing and mocking framework for C/C++"
+HOMEPAGE="https://cpputest.github.io/ https://github.com/cpputest/cpputest"
+SRC_URI="https://github.com/cpputest/cpputest/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( >=dev-cpp/gtest-1.8.0 )"
+
+DOCS=( AUTHORS README.md README_CppUTest_for_C.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}