summaryrefslogtreecommitdiff
path: root/dev-util/ctags/ctags-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-30 04:47:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-30 04:47:47 +0100
commit048bd060badd229e3bb596029874760a86d27060 (patch)
tree255c77a2abedb5474cd77d0b3cac24551de7771d /dev-util/ctags/ctags-99999999.ebuild
parent8993ea73a9714d22178ba6ada8c04be83cd71ec7 (diff)
gentoo auto-resync : 30:08:2022 - 04:47:47
Diffstat (limited to 'dev-util/ctags/ctags-99999999.ebuild')
-rw-r--r--dev-util/ctags/ctags-99999999.ebuild35
1 files changed, 22 insertions, 13 deletions
diff --git a/dev-util/ctags/ctags-99999999.ebuild b/dev-util/ctags/ctags-99999999.ebuild
index 3b3948787072..ceadc8424f8a 100644
--- a/dev-util/ctags/ctags-99999999.ebuild
+++ b/dev-util/ctags/ctags-99999999.ebuild
@@ -1,38 +1,46 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit autotools python-any-r1
DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
HOMEPAGE="https://ctags.io/ https://github.com/universal-ctags/ctags"
+
if [[ ${PV} == *99999999* ]] ; then
- inherit git-r3
EGIT_REPO_URI="https://github.com/universal-ctags/ctags"
+ inherit git-r3
else
SRC_URI="https://github.com/universal-ctags/ctags/archive/refs/tags/p5.9.${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-p5.9.${PV}"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ S="${WORKDIR}"/${PN}-p5.9.${PV}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="json xml yaml"
+IUSE="json pcre test xml yaml"
+RESTRICT="!test? ( test )"
DEPEND="
json? ( dev-libs/jansson:= )
+ pcre? ( dev-libs/libpcre2 )
xml? ( dev-libs/libxml2:2 )
yaml? ( dev-libs/libyaml )
"
-RDEPEND="
- ${DEPEND}
- app-eselect/eselect-ctags
-"
+RDEPEND="${DEPEND}"
BDEPEND="
dev-python/docutils
virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
"
+IDEPEND="app-eselect/eselect-ctags"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
src_prepare() {
# Ignore check-genfile test (calls git which errors out)
@@ -48,6 +56,7 @@ src_prepare() {
src_configure() {
econf \
$(use_enable json) \
+ $(use_enable pcre pcre2) \
$(use_enable xml) \
$(use_enable yaml) \
--disable-etags \
@@ -57,7 +66,7 @@ src_configure() {
src_install() {
emake prefix="${ED}"/usr mandir="${ED}"/usr/share/man install
- # namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # Namepace collision with X/Emacs-provided /usr/bin/ctags -- we
# rename ctags to exuberant-ctags (Mandrake does this also).
mv "${ED}"/usr/bin/{ctags,exuberant-ctags} || die
mv "${ED}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
@@ -66,8 +75,8 @@ src_install() {
pkg_postinst() {
eselect ctags update
- if [[ -z "$REPLACING_VERSIONS" ]]; then
- elog "You can set the version to be started by /usr/bin/ctags through"
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "You can set the version to be started by ${EROOT}/usr/bin/ctags through"
elog "the ctags eselect module. \"man ctags.eselect\" for details."
fi
}