summaryrefslogtreecommitdiff
path: root/dev-util/cvise/cvise-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-util/cvise/cvise-1.6.0.ebuild
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-util/cvise/cvise-1.6.0.ebuild')
-rw-r--r--dev-util/cvise/cvise-1.6.0.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-util/cvise/cvise-1.6.0.ebuild b/dev-util/cvise/cvise-1.6.0.ebuild
deleted file mode 100644
index ac8d916a8431..000000000000
--- a/dev-util/cvise/cvise-1.6.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-: ${CMAKE_MAKEFILE_GENERATOR=ninja}
-PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake llvm python-single-r1
-
-DESCRIPTION="Super-parallel Python port of the C-Reduce"
-HOMEPAGE="https://github.com/marxin/cvise/"
-SRC_URI="
- https://github.com/marxin/cvise/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-LLVM_MAX_SLOT=12
-DEPEND="
- || (
- sys-devel/clang:12
- sys-devel/clang:11
- sys-devel/clang:10
- )
- <=sys-devel/clang-$(( LLVM_MAX_SLOT + 1 )):="
-RDEPEND="${DEPEND}
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/pebble[${PYTHON_USEDEP}]
- ')
- dev-util/unifdef
- sys-devel/flex"
-BDEPEND="
- ${PYTHON_DEPS}
- sys-devel/flex
- test? (
- $(python_gen_cond_dep '
- dev-python/pebble[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ')
- )"
-
-llvm_check_deps() {
- has_version "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- python-single-r1_pkg_setup
- llvm_pkg_setup
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- pytest -vv || die
-}