summaryrefslogtreecommitdiff
path: root/dev-util/cvise/cvise-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 01:15:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 01:15:40 +0100
commitc1bd8495f43d1e8a084ac779db6e4623aaa8d6ad (patch)
treee149dfa502bb9b798db46039ff95a0ed656a5567 /dev-util/cvise/cvise-2.6.0.ebuild
parentab6ac5a7942816b5b14186dc53e1b17ea7df200a (diff)
gentoo auto-resync : 04:10:2022 - 01:15:40
Diffstat (limited to 'dev-util/cvise/cvise-2.6.0.ebuild')
-rw-r--r--dev-util/cvise/cvise-2.6.0.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-util/cvise/cvise-2.6.0.ebuild b/dev-util/cvise/cvise-2.6.0.ebuild
new file mode 100644
index 000000000000..ed819e732b93
--- /dev/null
+++ b/dev-util/cvise/cvise-2.6.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake llvm python-single-r1
+
+DESCRIPTION="Super-parallel Python port of the C-Reduce"
+HOMEPAGE="https://github.com/marxin/cvise/"
+SRC_URI="
+ https://github.com/marxin/cvise/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+LLVM_MAX_SLOT=15
+DEPEND="
+ || (
+ sys-devel/clang:15
+ sys-devel/clang:14
+ sys-devel/clang:13
+ )
+ <sys-devel/clang-$(( LLVM_MAX_SLOT + 1 )):=
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pebble[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ ')
+ dev-util/unifdef
+ sys-devel/flex
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/flex
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pebble[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.0-no-werror-cflags.patch
+)
+
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ llvm_pkg_setup
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ epytest
+}
+
+src_install() {
+ cmake_src_install
+
+ python_fix_shebang "${ED}"/usr/bin/cvise
+}