summaryrefslogtreecommitdiff
path: root/dev-util/cvise/cvise-2.7.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-02 09:28:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-02 09:28:30 +0100
commitbc3875d3a71ac3fdb07c0fcf863843b4fdfcf0c0 (patch)
treee255548891f2188ab2594eedde60d6f426ef24ed /dev-util/cvise/cvise-2.7.0-r1.ebuild
parentdef28ad1de5a6853465d7ff8f626cda6a774cd9e (diff)
gentoo auto-resync : 02:06:2023 - 09:28:30
Diffstat (limited to 'dev-util/cvise/cvise-2.7.0-r1.ebuild')
-rw-r--r--dev-util/cvise/cvise-2.7.0-r1.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/dev-util/cvise/cvise-2.7.0-r1.ebuild b/dev-util/cvise/cvise-2.7.0-r1.ebuild
deleted file mode 100644
index 0c599e87daf6..000000000000
--- a/dev-util/cvise/cvise-2.7.0-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit cmake llvm python-single-r1
-
-DESCRIPTION="Super-parallel Python port of the C-Reduce"
-HOMEPAGE="https://github.com/marxin/cvise/"
-SRC_URI="
- https://github.com/marxin/cvise/archive/v${PV}.tar.gz -> ${P}.tar.gz
-"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-LLVM_MAX_SLOT=16
-DEPEND="
- || (
- sys-devel/clang:16
- sys-devel/clang:15
- sys-devel/clang:14
- )
- <sys-devel/clang-$(( LLVM_MAX_SLOT + 1 )):=
-"
-RDEPEND="
- ${DEPEND}
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/pebble[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- ')
- dev-util/unifdef
- sys-devel/flex
-"
-BDEPEND="
- ${PYTHON_DEPS}
- sys-devel/flex
- test? (
- $(python_gen_cond_dep '
- dev-python/pebble[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ')
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-llvm16.patch
-)
-
-llvm_check_deps() {
- has_version "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- python-single-r1_pkg_setup
- llvm_pkg_setup
-}
-
-src_prepare() {
- sed -i -e 's:-Werror::' -e '/CMAKE_CXX_FLAGS_REL/d' CMakeLists.txt || die
- cmake_src_prepare
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- epytest
-}
-
-src_install() {
- cmake_src_install
-
- python_fix_shebang "${ED}"/usr/bin/cvise
-}