summaryrefslogtreecommitdiff
path: root/dev-util/debugedit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /dev-util/debugedit
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'dev-util/debugedit')
-rw-r--r--dev-util/debugedit/Manifest5
-rw-r--r--dev-util/debugedit/debugedit-4.14.2.ebuild89
-rwxr-xr-xdev-util/debugedit/files/update.sh84
-rw-r--r--dev-util/debugedit/metadata.xml8
4 files changed, 96 insertions, 90 deletions
diff --git a/dev-util/debugedit/Manifest b/dev-util/debugedit/Manifest
index e9b6bda9e5bd..690267d327fc 100644
--- a/dev-util/debugedit/Manifest
+++ b/dev-util/debugedit/Manifest
@@ -1,5 +1,6 @@
AUX debugedit-5.3.5-DWARF-4.patch 3235 BLAKE2B 6c12d8dc99b746fb2b5b813fed429f94cc4b0e737a6cb287f4741705b94782ef9bfd2a87e3284a63ddba20961d0a676823ac4145247edc328c46087d95842a2c SHA512 594bed4c2433e15c840316ca132619fc2b65ea5477cfe416ef851414d44932b3f8e75d006025eefbfc9c6cdcea956ff9ffc28dd4ef4fe5858a486ce5d08f43af
-AUX update.sh 1690 BLAKE2B f2f913fbbc3e06f1ee5ae8423253c67080471dfb0176e6c1b4ef3665a7b3b1ab24d7811ea8611c8afbd5b56072c12c0b97b08f87faf176d160ecee19f57f624e SHA512 5b271427d6391f717286289c5ec6eb794e99b7f0bd966100d3db03f84507000bc9256526f4ad6cdf809ff1800d53d5ed64d76bb14733507563d7a6123c9fc422
DIST debugedit-5.3.5.tar.bz2 27799 BLAKE2B f81b39122502afe66386b962d0e50e9a16a314f31acf2a44c6d53f16d24ac91b62483a67fed43d085c3dd573adcd312cbb5e15c214fd8f00bc5415835c2caa37 SHA512 afac800a8f2e035705fcf997500d8fd2c3dc658850f47754863e8811db97859748721c5a252cc90dc81d07bf08763a9507e2272e983ee3f6bf16d8016fe5b8c9
+DIST rpm-4.14.2.tar.bz2 4151934 BLAKE2B eb7e32dd736a195f2e5effc184ee8f2c700dcaf80477574c2112b6c96504d86a67c81e611f82ea35ce244e95fad339bd262eb51c35ada5eeffa8d306b6938cb7 SHA512 22e309e8be936e6070430cedd6f5ea0c3871db4c6aadd0d567a9c418796c178c8dd45d44920d7eaa66681790cc2821347affe471cb215d7a490fe7947fbf291c
EBUILD debugedit-0.5.3.5-r1.ebuild 937 BLAKE2B dc741f4fc4f880fffe5775067878d47e357a904acc79bdc69d9d5d7f2f95fcd41f5de34022cf73eb396e9a0d9813ddfe5245724830b069c1cc8d80ab6d462b83 SHA512 7553d4e2fa0ca9c2d65b52636af1ee775eba337bbd7313bb63f6392dd6db140fe81eb513d64b89a4bc07b04b7d80b2f3f24be13b76001f15dff057a7f62de407
-MISC metadata.xml 253 BLAKE2B 295e9d6d93aaa12af413972e1590c67087801cc09c9aa6b59d4606c0f4106d1dacf2baa9858559083b4c6d91beeef218d0729e8593a33788958da6d2897e8ce2 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555
+EBUILD debugedit-4.14.2.ebuild 1722 BLAKE2B fdbdd4ca1d9b85a1bc63de6eae867bddb873ef499190e7c3626af621cb1be6ddb333ac78f03c1745113f81b09cdd62461e4d313c121a81f6396aeb0a1f2f13ac SHA512 dc3854d27602108bb7db0fb25f3155b3bf52881a2a4991ac4ef24e680c871cc7bd7c56a161dbe9e419de0f5a0ad9379eb8ce66889df49ba14111a0769dfce7ea
+MISC metadata.xml 247 BLAKE2B 1750cec57189e711ca5eba89a78e1d317f0839fa53564fbd39b4e955c28d98f4ae04caf9069afc20a18536cdc92b30fe7b15eb086767c742bad07d9980cfd24b SHA512 d6e2ea8a9d74791bcbf3d6311a66bafc20b8f4db3a576d9a8d54b86d7afb231122b8d87f71f3f46360980adf8d815c633b6d5041f9a30fc8656e8fb66057a282
diff --git a/dev-util/debugedit/debugedit-4.14.2.ebuild b/dev-util/debugedit/debugedit-4.14.2.ebuild
new file mode 100644
index 000000000000..754bbccb0cf1
--- /dev/null
+++ b/dev-util/debugedit/debugedit-4.14.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+MY_P=rpm-${PV}
+DESCRIPTION="Stand-alone debugedit from RPM"
+HOMEPAGE="http://www.rpm.org
+ https://github.com/rpm-software-management/rpm"
+SRC_URI="http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sys-libs/zlib:=
+ >=dev-libs/popt-1.7
+ dev-libs/elfutils
+ dev-libs/nss
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eapply_user
+
+ # cheat it into believing we're bundling db
+ mkdir -p db/dist || die
+ touch db/dist/configure || die
+ chmod +x db/dist/configure || die
+ echo 'install:' > db3/Makefile || die
+
+ # TODO: why do we need to do this?
+ mkdir rpm || die
+ find -name '*.h' -exec cp {} rpm/ ';' || die
+}
+
+src_configure() {
+ append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
+ local myconf=(
+ # force linking to static librpmio
+ --disable-shared
+
+ # disable linking compression libraries
+ ac_cv_header_bzlib_h=no
+ ac_cv_header_lzma_h=no
+ --disable-zstd
+
+ # fake some libraries we don't use
+ ac_cv_header_magic_h=yes
+ ac_cv_lib_magic_magic_open=yes
+
+ # use nss as crypto provider
+ --with-crypto=nss
+
+ # disable other stuff irrelevant to debugedit
+ --disable-nls
+ --disable-python
+ --without-acl
+ --without-archive
+ --without-cap
+ --without-external-db
+ --without-hackingdocs
+ --without-lua
+ --without-selinux
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake -C misc
+ emake -C rpmio
+ emake debugedit
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ dobin debugedit
+}
diff --git a/dev-util/debugedit/files/update.sh b/dev-util/debugedit/files/update.sh
deleted file mode 100755
index 3fed29ad6dc2..000000000000
--- a/dev-util/debugedit/files/update.sh
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/bin/bash
-
-DISTDIR="$(portageq envvar DISTDIR 2>/dev/null)"
-DISTDIR="${DISTDIR:-/usr/portage/distfiles}"
-if [[ ! -d "${DISTDIR}" ]] ; then
- echo "No DISTDIR found."
- exit 1
-fi
-
-PN=debugedit
-
-gentoo_functions="/lib/gentoo/functions.sh"
-if [[ -f "${gentoo_functions}" ]] ; then
- . "${gentoo_functions}"
-else
- echo "Failed to source ${gentoo_functions} file."
- echo "Please install sys-apps/gentoo-functions package."
- exit 1
-fi
-
-set -e
-
-einfo "Getting updated index"
-rm -f index.html
-wget -q http://rpm5.org/
-
-PV=$(sed -n '/Production:/{n;s:.*RPM ::;s:<.*::;p;q}' index.html)
-einfo "Latest upstream version: ${PV}"
-rm -f index.html
-
-P="${PN}-${PV}"
-A=${P}.tar.bz2
-
-e=${P}.ebuild
-if [[ -e ../${e} ]] ; then
- einfo "All up to date"
- exit 0
-fi
-
-#tf=${DISTDIR}/${A}
-#if [[ ! -e ${tf} ]] ; then
-# einfo "Cannot find ${tf}"
-# exit 0
-#fi
-
-einfo "Fetching latest rpm tarball"
-r=rpm-${PV}
-wget -nv http://rpm5.org/files/rpm/rpm-${PV%.*}/${r}.tar.gz -P ${DISTDIR} -c
-
-einfo "Unpacking ${r}"
-rm -rf ${r}
-tar xf ${DISTDIR}/${r}.tar.gz
-
-einfo "Creating ${P}"
-rm -rf ${P}
-mkdir ${P}
-cp Makefile ${r}/tools/{hashtab.?,debugedit.c} ${P}/
-pushd ${P} >/dev/null
-more=true
-while ${more} ; do
- more=false
- for h in $(grep '#include' *.[ch] | awk '{print $NF}' | sed 's:[<>"]::g') ; do
- [[ ${h} == */* ]] && continue
- rh=$(find ../${r} -name ${h##*/})
- if [[ -n ${rh} ]] && [[ ! -e ${rh##*/} ]] ; then
- # don't copy glibc includes
- if ! grep -qs 'This file is part of the GNU C Library' ${rh} ; then
- cp ${rh} ./
- more=true
- fi
- fi
- done
-done
-popd >/dev/null
-tar jcf ${A} ${P}
-
-einfo "Testing build"
-pushd ${P} >/dev/null
-make -s
-popd >/dev/null
-
-einfo "Cleaning up"
-rm -rf ${P} ${r}
-du -b ${A}
diff --git a/dev-util/debugedit/metadata.xml b/dev-util/debugedit/metadata.xml
index 56c124413057..0319eec4c8be 100644
--- a/dev-util/debugedit/metadata.xml
+++ b/dev-util/debugedit/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
-</maintainer>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
</pkgmetadata>