summaryrefslogtreecommitdiff
path: root/dev-util/dialog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/dialog
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/dialog')
-rw-r--r--dev-util/dialog/Manifest7
-rw-r--r--dev-util/dialog/dialog-1.3.20170131.ebuild51
-rw-r--r--dev-util/dialog/dialog-1.3.20171209.ebuild52
-rw-r--r--dev-util/dialog/dialog-1.3.20180621.ebuild51
-rw-r--r--dev-util/dialog/metadata.xml11
5 files changed, 172 insertions, 0 deletions
diff --git a/dev-util/dialog/Manifest b/dev-util/dialog/Manifest
new file mode 100644
index 000000000000..266c8911cbc3
--- /dev/null
+++ b/dev-util/dialog/Manifest
@@ -0,0 +1,7 @@
+DIST dialog-1.3-20170131.tgz 507783 BLAKE2B a98c436eabc8d06619bd64a8b1d647a0712630f0f89565253636ef2f38333ca6926177aa0c2001305b0c06fc7a1f576cda87da493183402ef9ec3cdc3fa8be23 SHA512 818b4e9d0d5ee55377b78ccceacf59a78e5e6d6fbc09e24a19e62b4988ff8de32f3364132b9ee88c86e126114eda45c82d86397d5f26fae81a6bda91be979786
+DIST dialog-1.3-20180621.tgz 529123 BLAKE2B bb085e93a0eaedd1fc517bcfe080f8dbf61bf0b28003b38356d66c324baed7dcd2f76917676a1894e76bf3a7d58d3090c95e45624dae37e3e2e885282ab9c5bb SHA512 1c6d794af50a12294e32b99fd9d3eb9451ac4a2f21c5567848b59c7a316b3058463c41fb8f9eb0bce68edbbe463234a6ec893f7a013ceb953eb5da0effe0d274
+DIST dialog_1.3-20171209.orig.tar.gz 511503 BLAKE2B db633f882cce8a0ecd1446c26b305f5567bcdc0fb8e073ff3a443fbf56662638685578040ecd21220192c069899998f587aa04db8185074b4c8af957df77c49c SHA512 0355578bc64e2c75a2aae3ae83aff62eae60556a2890d50a72988efa76b82055755922bc1156a92370d773524865e76b8a0ddcde77fb6e6b5774c987fc22dee8
+EBUILD dialog-1.3.20170131.ebuild 1277 BLAKE2B 1cd46769259be314020f8f638ede023ae62f8c0c6c0d007baf8f364f018f00619301026e17bc956b53c291a2a22afacb70188e7a6946cc975a795aa9d9fa40f5 SHA512 9f72fa481b62e1ca43aee9cbc5856e139fad8c3b0d02f75fd33b8708437051eecc82c926fcc3a30f65e1829f232f92e3057fc25fe28794bf144a76535bcf8ada
+EBUILD dialog-1.3.20171209.ebuild 1350 BLAKE2B a2ae71b554dc8f96da4422d00ffbb49cf3af2456a58e97e8151db89ff16903200108cee08da78fa2e8dab1b36909c2222ad4a6336beba1f4010bdf6d7266f790 SHA512 52522ede770c6101897f8eecc5b0c9ed82c5ddab01a092cde57f7e08052e31188386eae7fa0a9044317b5d25c63502b69aa09dfa535780473a89888f1342ad47
+EBUILD dialog-1.3.20180621.ebuild 1276 BLAKE2B b21d421081fef21de326210e5117f0223203444ac0ae5ef1b4cc972d2fd57c46c0f2b50594a429ff7cd2b7a0e390f372d3781c5c42be65c7b4f2d84488e0137f SHA512 fd98134e5dd69bc3728b40b71933a5e49f3df34f8e22ec5baa02e8eb267ed2191d889086df23e263cd819d31b6363af4f6205a9989a03039ac0c84c9d8620bed
+MISC metadata.xml 341 BLAKE2B 84cb58bb0ffe236825ae28f7f277c172eb8e8ec279aec915cdac1078342272a180aceb72400817be94b01568c24c4588d6423baa2be02c70a9971840a7e62650 SHA512 b194bfc5daa545724eaa7ec7dcc5618ec87249158d5e8fcb01a76375960b2d9dd012e596c0fc8e0d9c94eb39175a6b4424257cf0828cc73956c7a68ff4749da8
diff --git a/dev-util/dialog/dialog-1.3.20170131.ebuild b/dev-util/dialog/dialog-1.3.20170131.ebuild
new file mode 100644
index 000000000000..6584c3579105
--- /dev/null
+++ b/dev-util/dialog/dialog-1.3.20170131.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib versionator
+
+MY_P="${PN}-$(replace_version_separator 2 '-')"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="http://invisible-island.net/dialog/dialog.html"
+SRC_URI="ftp://invisible-island.net/${PN}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0/14"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2-r5:=[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !minimal? ( sys-devel/libtool )
+ !<=sys-freebsd/freebsd-contrib-8.9999
+"
+
+src_prepare() {
+ default
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath-hack \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts=$(usex static-libs '' '-shared') \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ prune_libtool_files
+}
diff --git a/dev-util/dialog/dialog-1.3.20171209.ebuild b/dev-util/dialog/dialog-1.3.20171209.ebuild
new file mode 100644
index 000000000000..76110e4b945f
--- /dev/null
+++ b/dev-util/dialog/dialog-1.3.20171209.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib versionator
+
+DEB_P="${PN}_$(replace_version_separator 2 '-')"
+DIA_P="${PN}-$(replace_version_separator 2 '-')"
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="https://invisible-island.net/dialog/dialog.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${DEB_P}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/14"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2-r5:=[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !minimal? ( sys-devel/libtool )
+ !<=sys-freebsd/freebsd-contrib-8.9999
+"
+S=${WORKDIR}/${DIA_P}
+
+src_prepare() {
+ default
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath-hack \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts=$(usex static-libs '' '-shared') \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ prune_libtool_files
+}
diff --git a/dev-util/dialog/dialog-1.3.20180621.ebuild b/dev-util/dialog/dialog-1.3.20180621.ebuild
new file mode 100644
index 000000000000..ffa55f6cd40c
--- /dev/null
+++ b/dev-util/dialog/dialog-1.3.20180621.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib versionator
+
+DIA_P="${PN}-$(replace_version_separator 2 '-')"
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="https://invisible-island.net/dialog/"
+SRC_URI="https://dev.gentoo.org/~jer/${DIA_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2-r5:=[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !minimal? ( sys-devel/libtool )
+ !<=sys-freebsd/freebsd-contrib-8.9999
+"
+S=${WORKDIR}/${DIA_P}
+
+src_prepare() {
+ default
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath-hack \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts=$(usex static-libs '' '-shared') \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ prune_libtool_files
+}
diff --git a/dev-util/dialog/metadata.xml b/dev-util/dialog/metadata.xml
new file mode 100644
index 000000000000..7c5b4a32485b
--- /dev/null
+++ b/dev-util/dialog/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+<email>livecd@gentoo.org</email>
+<name>Gentoo LiveCD Project</name>
+</maintainer>
+<use>
+<flag name="minimal">Disable library, install command-line program only</flag>
+</use>
+</pkgmetadata>