summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-10 09:27:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-10 09:27:33 +0000
commite80777b54c5b430ca044e16878f59a2020423d48 (patch)
treeb72b3422d129532b8f0ceb415c6e7c5109e3fe75 /dev-util/diffoscope
parentaa61828f226f3b30e6939408847d914a145fdf35 (diff)
gentoo auto-resync : 10:11:2022 - 09:27:33
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-226.ebuild120
2 files changed, 122 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index e7290f10b71a..7070955cd278 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,5 +1,7 @@
DIST diffoscope-223.tar.gz 3145330 BLAKE2B 47ebe733c6330c2c8a7a78dfaad4c364ac3570d5a691b889f3154dcc5f7bec7b97744f04433cf56544ca208233271bbbca8bb767ed43844786fca4e77505d95b SHA512 5f83177133fd4689a77fb08038222998f9597cd63b0f328d3ae55c2ef6f5136f55ab1f5841b70ce1f64a62d216e2332bb4cecb82a3edcc90a6a5841e95955d4c
DIST diffoscope-224.tar.gz 3145263 BLAKE2B 918de272781a7829ad4a16f5db3f8d98e05fd1c7e342e18028bf448bf94ede09d5c475a3c1cadf255fa35f46bc8912374cb6cedf2cea878dcaf59380188b084f SHA512 2efbf2ea45e3a43a86eb6a3432852e0eb5a299d3745d8acb3f8857638cb4775d4322d844f2020ed718e4d28419c8a5ca8ab26f66b9bedeea15da57f33a008909
+DIST diffoscope-226.tar.gz 3164328 BLAKE2B 96fbafcd00c695fd3391122b8468abb0bb27936c45d97d01b2e0bb44bb1f18dc46b7ed2c7cf365993d6303c96a6cc8aeaa780808f23c6dfee5066e0cb377456b SHA512 59e8fd73fcf6e94a603c7e5fa8793f4746e770b0ff84d13379e155d3b4eb91defed79b688109785b62ae5cca1faf9b536454b3107ea93aa361eb511916601615
EBUILD diffoscope-223.ebuild 3444 BLAKE2B ace11e44d106488caa6e2e2014236e1d5889667c48348ef29b6b34b719f5b95392cc0f2aaf73ecf0a01085263e4dea21c3ba4280802abca4fe95ac2c2c018c17 SHA512 e9cb6a0ec3fe55146081dd3336409c49112b55dda2e7edb97c9c0b6269ca29f9706dbf9b1cc5061d4d0869f980824ea8ebe447e191d015510af58a50014f659b
EBUILD diffoscope-224.ebuild 3446 BLAKE2B 24aa2e6955914e21505310a6c935ad141627be46c1a22505fe371e4c3e6623866a6984090967eaddbab9905391b299ea2fe1cc7714b2b7d2a9d068e105a45275 SHA512 562d8964cd5d939e7280ef1d69d7b034b76cf27072391b262536fb3502c9d915562cee2464dda4c5a3e67b210aa3cc8897aaa0616e50b6a04b9c433c93718b32
+EBUILD diffoscope-226.ebuild 3546 BLAKE2B 18cd87610740fc78a59edb01e5fc3ba390ce3f73b6a023cdd3fe3f0b14a4e24f41122beee19a644cca308110e998b64a1a1688996392045879c7826209f12a7b SHA512 5b975cef495c7dcbcc5d5fd9cae76439c0dc6381df9f425c41d704140e61883736fcbb808aea09b8c9e325be9e89843fbe190d42cfa7f91551e213e61aa12489
MISC metadata.xml 2078 BLAKE2B 3bb126836e45e8d4e5b6170a12219ec9cceb1a12dca4658211b1971cb16fa5593622642ade363904cf24df16de0749b957d0fc03838d2a9a004484d0b551c886 SHA512 382cefe0478282000b74e404cdd9d636a0323fceb55b97fd8545190628c319e0c5e213c7d082198e4b8b1fc693a52ce85c52b3ad831778e6fadbe6ba401782f5
diff --git a/dev-util/diffoscope/diffoscope-226.ebuild b/dev-util/diffoscope/diffoscope-226.ebuild
new file mode 100644
index 000000000000..24af754a0edd
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-226.ebuild
@@ -0,0 +1,120 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tlsh[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence of filemagic's magic.py breaks imports
+# of dev-python/python-magic: bug #716482
+RDEPEND+=" !dev-python/filemagic"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="
+ test? (
+ app-text/docx2txt
+ app-text/html2text
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+ tests/comparators/test_gif.py::test_has_visuals
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+
+ # Fails on ZFS
+ tests/test_main.py::test_non_unicode_filename
+
+ # Fails on (unreleased) LLVM 16 with minor difference
+ tests/comparators/test_macho.py::test_llvm_diff
+)
+
+distutils_enable_tests pytest