summaryrefslogtreecommitdiff
path: root/dev-util/directx-headers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-06 22:33:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-06 22:33:57 +0100
commitc4b3d05f2d4415c0d6f135a3ea0d2055d6e055b5 (patch)
tree3ed89f0ec34cf85a0c06c027a6889e7890e08db6 /dev-util/directx-headers
parent8965d348ad07c326c8e17e3137c151bcc98b0a53 (diff)
gentoo auto-resync : 06:09:2022 - 22:33:57
Diffstat (limited to 'dev-util/directx-headers')
-rw-r--r--dev-util/directx-headers/Manifest4
-rw-r--r--dev-util/directx-headers/directx-headers-1.606.4.ebuild30
-rw-r--r--dev-util/directx-headers/directx-headers-9999.ebuild30
-rw-r--r--dev-util/directx-headers/metadata.xml11
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/directx-headers/Manifest b/dev-util/directx-headers/Manifest
new file mode 100644
index 000000000000..f39d9cac3624
--- /dev/null
+++ b/dev-util/directx-headers/Manifest
@@ -0,0 +1,4 @@
+DIST directx-headers-1.606.4.tar.gz 352341 BLAKE2B 5b79e5fb0f807c7766708ac3467f0f8bbf82aa68e3aa71abc84c6791742ffe625a5fed4c36dceded9b372af5349e41e431266cadf21b173e4a659b39f840b41c SHA512 3fb4142f8ceedd8484f5f7dae5804a7a0012951de344936fbf22991d6ae659d4e5093e1627bfe51c3cb0859340b13171c4f6aa68377ec26ac05038acaad8c540
+EBUILD directx-headers-1.606.4.ebuild 650 BLAKE2B 9ba540c786a2d37cb6077cdd8ace5483c4cf042706afc262c09f6088946e4cf1186d6da31fd937d3d75f7953005cb54b274cf77335cb5818ed415f9e1987f104 SHA512 9cc4b43fc783d90679c17693afe5dfe51beeed88180c9a285f898bf608ede80164603333be6afb324116724131ca832c46382475154df5d2e6f16a59488cc5dc
+EBUILD directx-headers-9999.ebuild 650 BLAKE2B 9ba540c786a2d37cb6077cdd8ace5483c4cf042706afc262c09f6088946e4cf1186d6da31fd937d3d75f7953005cb54b274cf77335cb5818ed415f9e1987f104 SHA512 9cc4b43fc783d90679c17693afe5dfe51beeed88180c9a285f898bf608ede80164603333be6afb324116724131ca832c46382475154df5d2e6f16a59488cc5dc
+MISC metadata.xml 325 BLAKE2B 5f99ebc7e34bc34ed7ce7de68b4856195b45a4b482fa198972f3f054a4b945bb548a046b71e07ed2e89d3486b7259291bc1b5d09cfae739d0daa091d366a82e7 SHA512 f8ff1d6fafe3c2ed1837ab3db04a52351ccf851098046e0240c5619745682c2669aaa0791a792647d0af533cfc4f83b68171cc2afd05a30c532b918d42111216
diff --git a/dev-util/directx-headers/directx-headers-1.606.4.ebuild b/dev-util/directx-headers/directx-headers-1.606.4.ebuild
new file mode 100644
index 000000000000..e0d36de615c0
--- /dev/null
+++ b/dev-util/directx-headers/directx-headers-1.606.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=DirectX-Headers
+inherit meson-multilib
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/microsoft/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/microsoft/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}"/${MY_PN}-${PV}
+fi
+
+DESCRIPTION="DirectX header files and WSL stubs"
+HOMEPAGE="https://github.com/microsoft/DirectX-Headers"
+
+LICENSE="MIT"
+SLOT="0"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbuild-test=false
+ )
+
+ meson_src_configure
+}
diff --git a/dev-util/directx-headers/directx-headers-9999.ebuild b/dev-util/directx-headers/directx-headers-9999.ebuild
new file mode 100644
index 000000000000..e0d36de615c0
--- /dev/null
+++ b/dev-util/directx-headers/directx-headers-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=DirectX-Headers
+inherit meson-multilib
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/microsoft/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/microsoft/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}"/${MY_PN}-${PV}
+fi
+
+DESCRIPTION="DirectX header files and WSL stubs"
+HOMEPAGE="https://github.com/microsoft/DirectX-Headers"
+
+LICENSE="MIT"
+SLOT="0"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbuild-test=false
+ )
+
+ meson_src_configure
+}
diff --git a/dev-util/directx-headers/metadata.xml b/dev-util/directx-headers/metadata.xml
new file mode 100644
index 000000000000..06575fa191e1
--- /dev/null
+++ b/dev-util/directx-headers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">microsoft/DirectX-Headers</remote-id>
+ </upstream>
+</pkgmetadata>