summaryrefslogtreecommitdiff
path: root/dev-util/distro-info
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/distro-info
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/distro-info')
-rw-r--r--dev-util/distro-info/Manifest3
-rw-r--r--dev-util/distro-info/distro-info-0.14.ebuild93
-rw-r--r--dev-util/distro-info/metadata.xml12
3 files changed, 108 insertions, 0 deletions
diff --git a/dev-util/distro-info/Manifest b/dev-util/distro-info/Manifest
new file mode 100644
index 000000000000..755803e4909f
--- /dev/null
+++ b/dev-util/distro-info/Manifest
@@ -0,0 +1,3 @@
+DIST distro-info_0.14.tar.xz 26460 BLAKE2B eb34e31514f7acfd283ae9405132884ccae31b77d6cf7af3a8a341ac349d589cbd5d7828e763911fc490d6504edae4c90551b3d3cc3518eec1f47ab1dcc6ac60 SHA512 aa0055f21523e30fc7e9c94c92f87cbd05fc5d082ddc109d092e94dabafac7533ced984197797252eb698232b3d8f512b3c345ed6abef0ae074bf2770224955e
+EBUILD distro-info-0.14.ebuild 1920 BLAKE2B adec92fe296311cfc572751e60c13df5cd32fdbf63b81a6e5c1acf474cc9e3777cb235155c80ce4ccb744e23cb8dc0fd9190a4dae76eddca29c37197394c2811 SHA512 4c75ee6a854e6c8afc78a27fdef03799ff5c0a1c66c0f92cc058a04e00c950eb49b94f320309417a8b56bbc2143171a5a2235e45457f5abaa71e73778495addb
+MISC metadata.xml 367 BLAKE2B 867a3664c5bbd444d69af80af19994e07e3810349258e85c2afd0c838cb140aa3f3342ee1aa5e6862d1fd5130e7e09c1f9f30443827fe7df705f4273694c0784 SHA512 3eb0be47e7eb6bfb6d8eecee66a25183da436c38272e226e7819c8748774f3aae620eab7227414cb862734d4baf8fa060290c1b2371233141abcffd7b489c7b8
diff --git a/dev-util/distro-info/distro-info-0.14.ebuild b/dev-util/distro-info/distro-info-0.14.ebuild
new file mode 100644
index 000000000000..3f9afb1fe1d4
--- /dev/null
+++ b/dev-util/distro-info/distro-info-0.14.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+DISTUTILS_OPTIONAL=true
+
+inherit distutils-r1
+
+DESCRIPTION="Provides information about the Debian distributions' releases"
+HOMEPAGE="https://debian.org"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="dev-lang/perl:=
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${CDEPEND}
+ python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
+ test? (
+ dev-util/shunit2
+ dev-python/pylint[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${CDEPEND}
+ dev-util/distro-info-data"
+
+src_prepare() {
+ default
+
+ # 1. Gentoo do not provides dpkg vendor information
+ # 2. Strip *FLAGS
+ # 3. Strip predefined CFLAGS
+ # 4. Point to correct perl's vendorlib
+ # 5. Remove python tests - python eclass will be used instead
+ sed -e "/cd python && python/d" \
+ -e "/VENDOR/d" \
+ -e "/dpkg-buildflags/d" \
+ -e "s/-g -O2//g" \
+ -e "s:\$(PREFIX)/share/perl5/Debian:\$(PERL_VENDORLIB)/Debian:g" \
+ -e "/pyversions/d" \
+ -i "${S}"/Makefile || die
+}
+
+src_configure() {
+ default
+
+ if use python; then
+ pushd ./python > /dev/null || die
+ distutils-r1_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd ./python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+src_install() {
+ emake PERL_VENDORLIB=$(perl -e 'require Config; print "$Config::Config{'vendorlib'}\n";') \
+ DESTDIR="${D}" install
+
+ if use python; then
+ pushd ./python > /dev/null || die
+ distutils-r1_src_install
+ popd > /dev/null || die
+ fi
+}
+
+src_test() {
+ TZ=UTC default
+
+ if use python; then
+ python_test() {
+ esetup.py test
+ }
+
+ pushd ./python > /dev/null || die
+ distutils-r1_src_test
+ popd > /dev/null || die
+ fi
+}
diff --git a/dev-util/distro-info/metadata.xml b/dev-util/distro-info/metadata.xml
new file mode 100644
index 000000000000..425c7b2eae49
--- /dev/null
+++ b/dev-util/distro-info/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ykonotopov@gnome.org</email>
+ <name>Yuri Konotopov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>