summaryrefslogtreecommitdiff
path: root/dev-util/distro-info
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-util/distro-info
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-util/distro-info')
-rw-r--r--dev-util/distro-info/Manifest2
-rw-r--r--dev-util/distro-info/distro-info-1.0.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-util/distro-info/Manifest b/dev-util/distro-info/Manifest
index 09b92b3b6254..3957e90cb563 100644
--- a/dev-util/distro-info/Manifest
+++ b/dev-util/distro-info/Manifest
@@ -1,3 +1,5 @@
DIST distro-info_0.22.tar.xz 29104 BLAKE2B 88eab833ea34de9e62f858e1fb9acfb94efb60114d2213b8bbb77a440c114dbac70a1707d1469113c1a98ea94d953ffa36480c132c294fd8e22b816a444b25e1 SHA512 b9d97e469b9173651c1816f39cc2315622b46f1579cbaba29c417a51417425e90a45283e83c7efee35db78621df08997f5395c8c1b0259f69e5cd91dee65793f
+DIST distro-info_1.0.tar.xz 30908 BLAKE2B 8355e54919d83d09d3eb7983a35151f0e4253c62eefeccf4d1e614cef0bb7cecf466007c7789749c145674aa30324423f9977a26695d5de537f80d5eb069f371 SHA512 2d84b5845ff4e7ce8059fe83e9d64a380d6732e0e85bc889c948068579d27a86fd31f8e6b7d8cc256f4ff4631cd0ffd480835bf290452d3bc28469f5b3be9ddb
EBUILD distro-info-0.22.ebuild 1968 BLAKE2B 9c2e9c64077fedc8dbe4be14065189e6cb429857b6bcdf1d7f015fdefc0a3003c5e4440313099581975a2773290fbf1adcea9908e55f37f2d7e38231c3a4e6e8 SHA512 52c783c7292c7a1545673117883fea87011a9ccffa270a53f6d459dd49835e0e75c53fe5dbae5351083a878dba18d0fc6cf861ff205b7dc34e62642d02cf82da
+EBUILD distro-info-1.0.ebuild 1959 BLAKE2B 7a06b08402551735740bf65a7b6aa0cec9ba174de6445cc29a7cb3710488a9892f91b70c180893a838e2e2d59f3bada8ebb97a95e88d0df43382c2194890bbab SHA512 b8302fcdf1ca34fddbe12d2f1922bf77e7634ab7e7abdd0b36d2c8816c69ab40af07bb5671bb2a7eca59f3e964716aace5c1f4a435b53e49bd15556fd481109e
MISC metadata.xml 367 BLAKE2B 867a3664c5bbd444d69af80af19994e07e3810349258e85c2afd0c838cb140aa3f3342ee1aa5e6862d1fd5130e7e09c1f9f30443827fe7df705f4273694c0784 SHA512 3eb0be47e7eb6bfb6d8eecee66a25183da436c38272e226e7819c8748774f3aae620eab7227414cb862734d4baf8fa060290c1b2371233141abcffd7b489c7b8
diff --git a/dev-util/distro-info/distro-info-1.0.ebuild b/dev-util/distro-info/distro-info-1.0.ebuild
new file mode 100644
index 000000000000..fb1bd4cbd9e6
--- /dev/null
+++ b/dev-util/distro-info/distro-info-1.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_OPTIONAL=true
+
+inherit distutils-r1
+
+DESCRIPTION="Provides information about the Debian distributions' releases"
+HOMEPAGE="https://debian.org"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="dev-lang/perl:=
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${COMMON_DEPEND}
+ python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
+ test? (
+ dev-util/shunit2
+ dev-python/pylint[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/distro-info-data"
+
+src_prepare() {
+ default
+
+ # 1. Gentoo do not provides dpkg vendor information
+ # 2. Strip *FLAGS
+ # 3. Strip predefined CFLAGS
+ # 4. Point to correct perl's vendorlib
+ # 5. Remove python tests - python eclass will be used instead
+ sed -e "/cd python && python/d" \
+ -e "/VENDOR/d" \
+ -e "/dpkg-buildflags/d" \
+ -e "s/-g -O2//g" \
+ -e "s:\$(PREFIX)/share/perl5/Debian:\$(PERL_VENDORLIB)/Debian:g" \
+ -e "/pyversions/d" \
+ -i "${S}"/Makefile || die
+}
+
+src_configure() {
+ default
+
+ if use python; then
+ pushd ./python > /dev/null || die
+ distutils-r1_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd ./python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+src_install() {
+ emake PERL_VENDORLIB=$(perl -e 'require Config; print "$Config::Config{'vendorlib'}\n";' || die) \
+ DESTDIR="${D}" install
+
+ if use python; then
+ pushd ./python > /dev/null || die
+ distutils-r1_src_install
+ popd > /dev/null || die
+ fi
+}
+
+src_test() {
+ TZ=UTC default
+
+ if use python; then
+ python_test() {
+ esetup.py test
+ }
+
+ pushd ./python > /dev/null || die
+ distutils-r1_src_test
+ popd > /dev/null || die
+ fi
+}