summaryrefslogtreecommitdiff
path: root/dev-util/flawfinder/flawfinder-1.31.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/flawfinder/flawfinder-1.31.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/flawfinder/flawfinder-1.31.ebuild')
-rw-r--r--dev-util/flawfinder/flawfinder-1.31.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/flawfinder/flawfinder-1.31.ebuild b/dev-util/flawfinder/flawfinder-1.31.ebuild
new file mode 100644
index 000000000000..6faab65e58ae
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-1.31.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="http://www.dwheeler.com/flawfinder/"
+SRC_URI="http://www.dwheeler.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc announcement ChangeLog README announcement
+ dodoc flawfinder.pdf
+ python_fix_shebang "${ED}"usr/bin/flawfinder
+}