summaryrefslogtreecommitdiff
path: root/dev-util/gcovr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
commitd2ed973482fdd800013658e83a61709b29e0a80f (patch)
tree57ea7666a57b5a05a4c8866e4915e90b4a6e7c94 /dev-util/gcovr
parent9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (diff)
gentoo auto-resync : 27:06:2024 - 07:59:39
Diffstat (limited to 'dev-util/gcovr')
-rw-r--r--dev-util/gcovr/Manifest1
-rw-r--r--dev-util/gcovr/gcovr-7.2-r1.ebuild260
2 files changed, 261 insertions, 0 deletions
diff --git a/dev-util/gcovr/Manifest b/dev-util/gcovr/Manifest
index 60a7cddd5a2d..68e37543a4c9 100644
--- a/dev-util/gcovr/Manifest
+++ b/dev-util/gcovr/Manifest
@@ -1,5 +1,6 @@
DIST gcovr-6.0.tar.gz 1054940 BLAKE2B 1947950d06926cf48d456e6bc389db46cfe4c7ed0395da1ebdb75aa1ea4b85f3cea536d77a4ddca5621885daaaf54462160592a5a384247f12ad3ed5c299b0b7 SHA512 3b4d30417b5000d2d28bc156dc9db43ba62cf8756aa5a9619391457d0042dc8eaf1743c5defdaabffb6b423bf2fcf8172b3e6c8795419758abc1acf4853de4bb
DIST gcovr-7.2.gh.tar.gz 2800014 BLAKE2B e334688f129868d9affe0fa5c5280eb7dd4c57825bec31f32d529c579f622e7c60985f8aad506bd714ebe00c47fd61b673ad2352e51a0fd8175777bb6a1c93e7 SHA512 fc4acbfeef48866c5c8884681375069c7308a86aaefe5b36e631240a96dcdc7c56b3e8d0c221f66dbbe29302b549c5c9b9c5e01bbf4103165b085ae33c369f55
EBUILD gcovr-6.0.ebuild 975 BLAKE2B 1d7c2fedfdbfa0757f009cf588e68068e9400693d19327af86af41097d490b8e06659782673f8cc2bf6c96d10bd3b497dfbfccc5327a5a40152d142ed8bd3568 SHA512 1cb95bdad3671f38aa06aa3a1a40fdd3542fb01f149df1c9da7bd52a1163f963e6ba05f3b84d91fe50d172f571629e8947819d954e9913ed74aab23001a83630
+EBUILD gcovr-7.2-r1.ebuild 7884 BLAKE2B f62e7ddc59cf5cd3a51c802705b04ee6f07eca5887123a7b6f02a9c205198e609e9e00f7f5f8cfa5c3f2d9d22bddcdf774c8b205e376e006d2d89b79f8e4bc05 SHA512 89c21679b5e5b4b5edc6c41064ed05d944e6941f860a4e0528a739378e808238e68cf1314f5add46e7ed67fe25334396d1ec8fad9d7ba9362c7549343973caad
EBUILD gcovr-7.2.ebuild 7848 BLAKE2B 46b6dbea5b05553d9dcc38510583eff704f19ef9a04620fe2c9577ebaa40e23c7fc2c95959163c5fb0413048766dba5b192cc7a5ca057a2d81284ce05b306a3f SHA512 4c806ef11538031293653c481ad431b9cdfeace4347a8d57cfde4b2fb09282ad51b8482c3344a8f8a1a536689ba7bd223f204454ce4500bab3bafcb26bd57f6f
MISC metadata.xml 326 BLAKE2B 0ff392fe3a804fc6d8ea83de983357676a8155dee2fbb5204baf0ead2800210ea30a0171398c71dc60b1d9423a6fd65c0a9032d4511caa459c9b4d4f70ee4132 SHA512 5f5a49bfbbd3d3b77314f7de0c5981a3e700b42733d1c4f6868a7c25d12bb6227ebd254925cbbb6a5d73bf8a0b9f99115d396009d55797e39b53dc43a1a79107
diff --git a/dev-util/gcovr/gcovr-7.2-r1.ebuild b/dev-util/gcovr/gcovr-7.2-r1.ebuild
new file mode 100644
index 000000000000..1d820d592f3c
--- /dev/null
+++ b/dev-util/gcovr/gcovr-7.2-r1.ebuild
@@ -0,0 +1,260 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit toolchain-funcs distutils-r1
+
+DESCRIPTION="A Python script for summarizing gcov data"
+HOMEPAGE="https://github.com/gcovr/gcovr"
+SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/yaxmldiff[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PATH="${TEST_DIR}/scripts:${PATH}" \
+ PYTHONPATH="${TEST_DIR}/lib"
+
+ # these tests assume gcc-8, and fail with newer gcc versions
+ local -a test_build_deselect=(
+ "add_coverages-coveralls"
+ "add_coverages-html"
+ "add_coverages-html"
+ "bad++char-coveralls"
+ "bad++char-html"
+ "calls-html"
+ "cmake_oos-coveralls"
+ "cmake_oos-html"
+ "cmake_oos_ninja-coveralls"
+ "cmake_oos_ninja-html"
+ "coexisting_object_directories-from_build_dir-cobertura"
+ "coexisting_object_directories-from_build_dir-html"
+ "coexisting_object_directories-from_build_dir-without_object_dir-cobertura"
+ "coexisting_object_directories-from_build_dir-without_object_dir-html"
+ "coexisting_object_directories-from_build_dir-without_object_dir-sonarqube"
+ "coexisting_object_directories-from_build_dir-without_object_dir-txt"
+ "coexisting_object_directories-from_build_dir-without_search_dir-cobertura"
+ "coexisting_object_directories-from_build_dir-without_search_dir-html"
+ "coexisting_object_directories-from_build_dir-without_search_dir-sonarqube"
+ "coexisting_object_directories-from_build_dir-without_search_dir-txt"
+ "coexisting_object_directories-from_root_dir-cobertura"
+ "coexisting_object_directories-from_root_dir-html"
+ "coexisting_object_directories-from_root_dir-without_object_dir-cobertura"
+ "coexisting_object_directories-from_root_dir-without_object_dir-html"
+ "coexisting_object_directories-from_root_dir-without_object_dir-sonarqube"
+ "coexisting_object_directories-from_root_dir-without_object_dir-txt"
+ "coexisting_object_directories-from_root_dir-without_search_dir-cobertura"
+ "coexisting_object_directories-from_root_dir-without_search_dir-html"
+ "coexisting_object_directories-from_root_dir-without_search_dir-sonarqube"
+ "coexisting_object_directories-from_root_dir-without_search_dir-txt"
+ "config-output-html"
+ "config-toml-html"
+ "config-toml-txt"
+ "decisions-html"
+ "decisions-json"
+ "decisions-neg-delta-html"
+ "different-function-lines-separate-coveralls"
+ "different-function-lines-separate-html"
+ "different-function-lines-use-0-coveralls"
+ "different-function-lines-use-0-html"
+ "different-function-lines-use-max-coveralls"
+ "different-function-lines-use-max-html"
+ "different-function-lines-use-min-coveralls"
+ "different-function-lines-use-min-html"
+ "dot-coveralls"
+ "dot-html"
+ "excl-branch-coveralls"
+ "excl-branch-html"
+ "excl-line-branch-coveralls"
+ "excl-line-branch-html"
+ "excl-line-coveralls"
+ "excl-line-custom-coveralls"
+ "excl-line-custom-html"
+ "excl-line-html"
+ "exclude-directories-relative-coveralls"
+ "exclude-directories-relative-html"
+ "exclude-lines-by-pattern-coveralls"
+ "exclude-lines-by-pattern-html"
+ "exclude-relative-coveralls"
+ "exclude-relative-from-unfiltered-tracefile-html"
+ "exclude-relative-html"
+ "exclude-throw-branches-cobertura"
+ "exclude-throw-branches-coveralls"
+ "exclude-throw-branches-html"
+ "exclude-throw-branches-jacoco"
+ "exclude-throw-branches-json"
+ "exclude-throw-branches-lcov"
+ "exclude-throw-branches-sonarqube"
+ "exclude-throw-branches-txt"
+ "filter-absolute-coveralls"
+ "filter-absolute-from-unfiltered-tracefile-html"
+ "filter-absolute-html"
+ "filter-relative-coveralls"
+ "filter-relative-from-unfiltered-tracefile-html"
+ "filter-relative-html"
+ "filter-relative-lib-coveralls"
+ "filter-relative-lib-from-unfiltered-tracefile-html"
+ "filter-relative-lib-html"
+ "html-css-html"
+ "html-default-html"
+ "html-encoding-cp1252-html"
+ "html-encoding-iso-8859-15-html"
+ "html-high-100-html"
+ "html-high-75-html"
+ "html-line-branch-html"
+ "html-medium-100-high-100-html"
+ "html-medium-50-html"
+ "html-nested-filter-html"
+ "html-nested-nonsort-html"
+ "html-nested-sort-casefold-html"
+ "html-nested-sort-percentage-html"
+ "html-nested-sort-uncovered-html"
+ "html-source-encoding-cp1252-html"
+ "html-source-encoding-utf8-html"
+ "html-tab-size-2-html"
+ "html-template-dir-html"
+ "html-themes-github-html"
+ "html-themes-html"
+ "html-title-html"
+ "linked-coveralls"
+ "linked-html"
+ "nested-coveralls"
+ "nested-html"
+ "nested2-coveralls"
+ "nested2-coveralls"
+ "nested2-html"
+ "nested2-html"
+ "nested2-use-existing-coveralls"
+ "nested2-use-existing-html"
+ "nested3-coveralls"
+ "no-markers-html"
+ "nobranch-coveralls"
+ "nobranch-html"
+ "noncode-coveralls"
+ "noncode-html"
+ "oos-coveralls"
+ "oos-html"
+ "oos2-coveralls"
+ "oos2-html"
+ "rounding-html"
+ "shadow-coveralls"
+ "shadow-html"
+ "shared_lib-coveralls"
+ "shared_lib-html"
+ "simple1-coveralls"
+ "simple1-dir-coveralls"
+ "simple1-dir-html"
+ "simple1-html"
+ "simple1-stdout-coveralls"
+ "simple1-stdout-html"
+ "sort-percentage-html"
+ "sort-uncovered-html"
+ "source_from_pipe-cobertura"
+ "source_from_pipe-coveralls"
+ "source_from_pipe-html"
+ "source_from_pipe-lcov"
+ "subfolder-includes-html"
+ "threaded-coveralls"
+ "threaded-html"
+ "update-data-coveralls"
+ "update-data-html"
+ "use-existing-coveralls"
+ "use-existing-html"
+ "wspace-coveralls"
+ "wspace-html"
+ )
+
+ local cc cc_ver
+ cc="$(tc-get-compiler-type)"
+ case "${cc}" in
+ gcc)
+ cc_ver="$(gcc-major-version)"
+
+ # a bunch of tests are broken on gcc-14
+ # https://bugs.gentoo.org/930680
+ if [[ $(gcc-major-version) -ge 14 ]]; then
+ test_build_deselect+=(
+ "calls-json"
+ "decisions-neg-delta-json"
+ "different-function-lines-separate-lcov"
+ "different-function-lines-use-0-lcov"
+ "different-function-lines-use-max-lcov"
+ "different-function-lines-use-min-lcov"
+ "dot-lcov"
+ "excl-branch-lcov"
+ "excl-line-json"
+ "excl-line-lcov"
+ "excl-line-branch-lcov"
+ "excl-line-custom-lcov"
+ "exclude-directories-relative-lcov"
+ "exclude-lines-by-pattern-lcov"
+ "exclude-relative-lcov"
+ "exclude-relative-from-unfiltered-tracefile-lcov"
+ "filter-absolute-lcov"
+ "filter-absolute-from-unfiltered-tracefile-lcov"
+ "filter-relative-lcov"
+ "filter-relative-from-unfiltered-tracefile-lcov"
+ "filter-relative-lib-lcov"
+ "filter-relative-lib-from-unfiltered-tracefile-lcov"
+ "linked-lcov"
+ "nested-lcov"
+ "nested2-lcov"
+ "nested3-lcov"
+ "no-markers-json"
+ "no-markers-lcov"
+ "noncode-json"
+ "noncode-lcov"
+ "oos-lcov"
+ "oos2-lcov"
+ "shadow-json"
+ "simple1-txt"
+ "simple1-json"
+ "simple1-dir-json"
+ "simple1-stdout-json"
+ "simple1-stdout-lcov"
+ "threaded-lcov"
+ "update-data-lcov"
+ "wspace-lcov"
+ )
+ fi
+ ;;
+ clang) cc_ver="$(clang-major-version)";;
+ # placeholder since tests need CC_REFERENCE to be string-number
+ *) cc_ver=1;;
+ esac
+
+ readarray -t EPYTEST_DESELECT < <(printf 'gcovr/tests/test_gcovr.py::test_build[%s]\n' "${test_build_deselect[@]}")
+
+ EPYTEST_DESELECT+=(
+ # tests that don't work in the ebuild environment
+ gcovr/tests/test_args.py::test_html_template_dir
+ gcovr/tests/test_args.py::test_multiple_output_formats_to_stdout
+ gcovr/tests/test_args.py::test_multiple_output_formats_to_stdout_1
+ )
+ local -x CC_REFERENCE="${cc}-${cc_ver}"
+
+ epytest gcovr
+}