summaryrefslogtreecommitdiff
path: root/dev-util/geany-plugins/geany-plugins-1.37.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-util/geany-plugins/geany-plugins-1.37.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-util/geany-plugins/geany-plugins-1.37.ebuild')
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.37.ebuild124
1 files changed, 0 insertions, 124 deletions
diff --git a/dev-util/geany-plugins/geany-plugins-1.37.ebuild b/dev-util/geany-plugins/geany-plugins-1.37.ebuild
deleted file mode 100644
index a1018068f128..000000000000
--- a/dev-util/geany-plugins/geany-plugins-1.37.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="A collection of different plugins for Geany"
-HOMEPAGE="https://plugins.geany.org"
-SRC_URI="https://plugins.geany.org/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
-
-IUSE="gtk2 ctags debugger enchant git gpg gtkspell lua markdown nls pretty-printer scope soup workbench"
-REQUIRED_USE="gtk2? ( !markdown )"
-
-DEPEND="
- dev-libs/glib:2
- >=dev-util/geany-1.37[gtk2=]
- !gtk2? ( x11-libs/gtk+:3 )
- gtk2? ( x11-libs/gtk+:2 )
- ctags? ( dev-util/ctags )
- debugger? (
- !gtk2? ( x11-libs/vte:2.91 )
- gtk2? ( x11-libs/vte:0 )
- )
- enchant? ( app-text/enchant:= )
- git? ( dev-libs/libgit2:= )
- gpg? ( app-crypt/gpgme:1= )
- gtkspell? (
- !gtk2? ( app-text/gtkspell:3= )
- gtk2? ( app-text/gtkspell:2 )
- )
- lua? ( dev-lang/lua:0= )
- markdown? (
- app-text/discount
- net-libs/webkit-gtk:4
- )
- pretty-printer? ( dev-libs/libxml2:2 )
- scope? (
- !gtk2? ( x11-libs/vte:2.91 )
- gtk2? ( x11-libs/vte:0 )
- )
- soup? ( net-libs/libsoup:2.4 )
- workbench? ( dev-libs/libgit2:= )
-"
-RDEPEND="${DEPEND}
- scope? ( sys-devel/gdb )
-"
-BDEPEND="virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-src_configure() {
- local myeconfargs=(
- --disable-cppcheck
- --disable-extra-c-warnings
- $(use_enable nls)
- --enable-utilslib
- # Plugins
- --enable-addons
- --enable-autoclose
- --enable-automark
- --enable-codenav
- --enable-commander
- --enable-defineformat
- --enable-geanyextrasel
- --enable-geanyinsertnum
- --enable-geanymacro
- --enable-geanyminiscript
- --enable-geanynumberedbookmarks
- --enable-geanyprj
- --enable-geanyvc $(use_enable gtkspell)
- --enable-keyrecord
- --enable-latex
- --enable-lineoperations
- --enable-lipsum
- --enable-overview
- --enable-pairtaghighlighter
- --enable-pohelper
- --enable-projectorganizer
- --enable-sendmail
- --enable-shiftcolumn
- --enable-tableconvert
- --enable-treebrowser
- --enable-vimode
- --enable-xmlsnippets
- $(use_enable debugger)
- $(use_enable ctags geanyctags)
- $(use_enable gtk2 geanydoc)
- $(use_enable lua geanylua)
- $(use_enable gpg geanypg)
- $(use_enable soup geniuspaste)
- $(use_enable git gitchangebar)
- $(use_enable markdown) --disable-peg-markdown # using app-text/discount instead
- $(use_enable pretty-printer)
- $(use_enable scope)
- $(use_enable enchant spellcheck)
- # Having updatechecker… when you’re using a package manager?
- $(use_enable soup updatechecker)
- $(use_enable workbench)
- # GeanyGenDoc requires ctpl which isn’t yet in portage
- --disable-geanygendoc
- # Require obsolete and vulnerable webkit-gtk versions
- --disable-devhelp
- --disable-webhelper
- # GTK 2 only
- --disable-geanypy
- --disable-multiterm
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- find "${D}" -name '*.la' -delete || die
-
- # make installs all translations if LINGUAS is empty
- if [[ -z "${LINGUAS-x}" ]]; then
- rm -r "${ED}/usr/share/locale/" || die
- fi
-}