summaryrefslogtreecommitdiff
path: root/dev-util/glade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-util/glade
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/Manifest4
-rw-r--r--dev-util/glade/glade-3.22.1.ebuild90
-rw-r--r--dev-util/glade/metadata.xml3
3 files changed, 96 insertions, 1 deletions
diff --git a/dev-util/glade/Manifest b/dev-util/glade/Manifest
index d51cc8f3482c..b2cd91790d84 100644
--- a/dev-util/glade/Manifest
+++ b/dev-util/glade/Manifest
@@ -1,4 +1,6 @@
AUX glade-3.14.1-doc-version.patch 853 BLAKE2B b7cad3cc9d49cfe24189ba21bffaec2c524d3c7953d722b3b03d57ad68297fee6757330c1a2d90f36bcfe52d1d9ef4d95b81eeb19109bc8957f671ac40d31573 SHA512 cc9aec06f6acdfdf538de7043f9f753768e0e4c26fa9eef7e52b4e42aa6fd3836185c18ffd51abfc2aa3e6f5b2472e68914112230d2b8856e8a3c61e9d865ecf
DIST glade-3.20.4.tar.xz 3534860 BLAKE2B f502e863f9acbd6580c043ff82dffb84ea8fdb833c0b6fdb8bbeeb7a7056a79416f1140472d23e0cdb14ed3bd06e17fca93ea663af690451001909aa4abfe478 SHA512 3da7781f74fa80e21336e49b9b36cf73b88ec9cf6f66a5c0e5d48ebc3382d87f5eb981b924704f04dfa4931e5691928a20c7cc73cca5b5f3a32e2348d6b87802
+DIST glade-3.22.1.tar.xz 3592952 BLAKE2B 53f769198a093ff5d4dc98bb4ea98c6e5195933caf24247a99db980312ae3398fca3abbd640d08c02e8fb5f8647ee3e4b18e65073b1500e9017ee0586993a331 SHA512 e1bdc49b89bc5010c0abf6357dbae05c921182655b2ee5a4b161af6adfd596cfbcd495c9851ba956abbf3d6156616a6c0e94640cd72cee11551ca388674ac908
EBUILD glade-3.20.4.ebuild 2386 BLAKE2B 8f4d42898dfe18c870f0ea90442c0ab98d43ea75299ce210a80b7527157a0f8e1bda0527c22f51c4832f6c42b6539e5294e112f822a2a94b156ac089313384fe SHA512 3cccd8c8e69e26ea881565673ed6883a68f00d11d5aa72386ca123f0c982ecac4af509359c1512517457b54c52aa5b58caac09116b6fc1c7592833ce34b348b9
-MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
+EBUILD glade-3.22.1.ebuild 2334 BLAKE2B e7309513a932bbcbbb039e45e9afca7cd15871132dc73ad8aa006b88d699b3d7830641c5b6c535968cfe08eeec6c542182e278be6ca1e001c8c1eff96ee91114 SHA512 ec1856591b08f2bf06840e0bdcccfe745097476f78c5b5d740d97651997c41714357b6a6e1acbb53c3618102938af4581dc6ac65f92d842f00e3d102628bf76d
+MISC metadata.xml 358 BLAKE2B 33f3b46ab877b311931205095fb2b357fe7fe2da8820944d32e8a16f2dbcf99033f95a17f4cefa4aa6d0f731c72d0f65683a8cc3b947ebf09d084f92e796f887 SHA512 8840ebde12f26a2caf856e75f3f706e3c9a7a7a771d0deeae99ca6b16f4bbeaf119bae7776a8a0bef8b7422f52ebd6498a8b5e862af4548886249386dcb44480
diff --git a/dev-util/glade/glade-3.22.1.ebuild b/dev-util/glade/glade-3.22.1.ebuild
new file mode 100644
index 000000000000..0106822b04d0
--- /dev/null
+++ b/dev-util/glade/glade-3.22.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 virtualx
+
+DESCRIPTION="A user interface designer for GTK+ and GNOME"
+HOMEPAGE="https://glade.gnome.org/"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="3.10/6" # subslot = suffix of libgladeui-2.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+IUSE="debug +introspection python webkit"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.53.2:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.20.0:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}] )
+ webkit? ( >=net-libs/webkit-gtk-2.12.0:4 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.41.0
+ dev-util/itstool
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+RESTRICT="test" # https://gitlab.gnome.org/GNOME/glade/issues/333
+
+PATCHES=(
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ "${FILESDIR}"/${PN}-3.14.1-doc-version.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-gladeui \
+ --enable-libtool-lock \
+ $(usex debug --enable-debug ' ') \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_enable webkit webkit2gtk)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ # modify name in .devhelp2 file to avoid shadowing with glade:3 docs
+ sed -e 's:name="gladeui":name="gladeui-2":' \
+ -i doc/html/gladeui.devhelp2 || die "sed of gladeui.devhelp2 failed"
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version dev-util/devhelp ; then
+ elog "You may want to install dev-util/devhelp for integration API"
+ elog "documentation support."
+ fi
+}
diff --git a/dev-util/glade/metadata.xml b/dev-util/glade/metadata.xml
index 39980802b1da..64de49b2607a 100644
--- a/dev-util/glade/metadata.xml
+++ b/dev-util/glade/metadata.xml
@@ -5,4 +5,7 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+<use>
+ <flag name="webkit">Build catalog support for <pkg>net-libs/webkit-gtk</pkg>:4 widgets.</flag>
+</use>
</pkgmetadata>