summaryrefslogtreecommitdiff
path: root/dev-util/glslang/glslang-1.3.216.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-util/glslang/glslang-1.3.216.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-util/glslang/glslang-1.3.216.ebuild')
-rw-r--r--dev-util/glslang/glslang-1.3.216.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/glslang/glslang-1.3.216.ebuild b/dev-util/glslang/glslang-1.3.216.ebuild
new file mode 100644
index 000000000000..35959e16caf4
--- /dev/null
+++ b/dev-util/glslang/glslang-1.3.216.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS="cmake"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
+ inherit git-r3
+else
+ SNAPSHOT_COMMIT="sdk-${PV}.0"
+ SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${SNAPSHOT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${SNAPSHOT_COMMIT}"
+fi
+
+DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="${PYTHON_DEPS}"
+
+# Bug 698850
+RESTRICT="test"